Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

WKND - OSGi Bundle Dependency Issue

Avatar

Avatar
Boost 1
Level 1
aembeginner
Level 1

Like

1 like

Total Posts

5 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
aembeginner
Level 1

Like

1 like

Total Posts

5 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
aembeginner
Level 1

11-09-2020

After I installed WKND to AEM, I noticed that I don't see some of components. I got the error after I added the "byline" component.

 
 

Screen Shot 2020-09-11 at 3.41.59 PM.png

 

Then, I found I have some dependency issues. 

Screen Shot 2020-09-11 at 3.19.03 PM.png

I went to http://localhost:4502/system/console/depfinder

Screen Shot 2020-09-11 at 3.25.34 PM.png

 

I was looking at other article, and tried a command from a terminal console (Mac), it didn't fix it.

          mvn -PautoInstallPackage -Padobe-public clean install

 

I deleted all installed WKND packages from a package manager (http://localhost:4502/crx/packmgr/index.jsp) and deleted the WKND bundle from OSGi and started over to install WKND files, but I got same issues. 

 

I appreciate if you can find out what I need to do. I'm a beginner of AEM, Java, and Eclipse. Thank you so much for your help. 

 

I took pom.xml screenshot just in case.

Screen Shot 2020-09-11 at 3.29.54 PM.png 

=== My System ===

macOS 10.15.6

Java 11.0.7

Maven 3.6.3

Node.js v12.18.0

npm 6.14.4

Git 2.24.3

AEM 6.5.5.0 

 

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,115 likes

Total Posts

3,149 posts

Correct Reply

1,072 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,115 likes

Total Posts

3,149 posts

Correct Reply

1,072 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile
Jörg_Hoh
Employee

14-09-2020

Looks like you did not use the release 0.0.4 version of the wknd tutorial, but used the un-released master-branch of the wknd-tutorial (in the screenshot I see the version number 0.0.5-SNAPSHOT). But according to the documentation this release is targeting AEM as a Cloud Service as "primary" version.

But the documentation also says, that if you want to use it on AEM 6.x (and not Cloud Service), you should use this command:

 

mvn clean install -PautoInstallSinglePackage -Pclassic

 

 

 

Answers (3)

Answers (3)

Avatar

Avatar
Boost 1
Level 1
aembeginner
Level 1

Like

1 like

Total Posts

5 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
aembeginner
Level 1

Like

1 like

Total Posts

5 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
aembeginner
Level 1

14-09-2020

Thank you so much for replying my issues!! @Arun_Patidar @Nikhil-Kumar @Jörg_Hoh 

 

I run this command, it worked!! Thank you sooooooo much to find out my issue. I appreciate all your help. 🙂

mvn clean install -PautoInstallSinglePackage -Pclassic

 

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,356 likes

Total Posts

3,227 posts

Correct Reply

917 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,356 likes

Total Posts

3,227 posts

Correct Reply

917 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

13-09-2020

Can you try with java 8.

Avatar

Avatar
Validate 1
MVP
Nikhil-Kumar
MVP

Likes

243 likes

Total Posts

256 posts

Correct Reply

38 solutions
Top badges earned
Validate 1
Ignite 3
Ignite 1
Give Back 5
Give Back 3
View profile

Avatar
Validate 1
MVP
Nikhil-Kumar
MVP

Likes

243 likes

Total Posts

256 posts

Correct Reply

38 solutions
Top badges earned
Validate 1
Ignite 3
Ignite 1
Give Back 5
Give Back 3
View profile
Nikhil-Kumar
MVP

13-09-2020

@aembeginner 

Sometime back I also used WKND sample project on 6.5.5 but didn't found any such issue. 
Below steps I followed to setup WKND on 6.5.5
1. Installed SP5 over 6.5
2. Installed latest ACS Commons package.
3. Deployed AEM WKND Project.


@Jörg_Hoh  @vanegi  @Arun_Patidar  Can you guys provide your inputs ?


Thanks,
Nikhil