Highlighted

Wknd Maven project

Avatar

Avatar

Karthick_Vijaya

Avatar

Karthick_Vijaya

Karthick_Vijaya

29-03-2019

Hi Team,

I have imported a Wknd project from Github and deployed in my local. I have created a new package under core bundle just say(com.adobe.aem.guides.wknd.core.newpackage) and created a some couple of java classes . I am getting an error as "com.adobe.aem.guides.wknd.core.*.Hello cannot be resolved to a type" when I am using those java class in my component.

Do we need to configure something on pom.xml for this?

Replies

Highlighted

Avatar

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281
Gaurav-Behl
MVP

29-03-2019

This could happen due to versions mismatch. Whatever article you followed, make sure you use correct maven archetype version as mentioned in tutorial and deploy in AEM version with Service Pack as mentioned in tutorial.

Highlighted

Avatar

Avatar

Prince_Shivhare

Avatar

Prince_Shivhare

Prince_Shivhare

29-03-2019

Could you please confirm if you bundle is active or not ?

Also which AEM version you are using and what WKND tutorial you have used. paste the link.

Avatar

Avatar

Karthick_Vijaya

Avatar

Karthick_Vijaya

Karthick_Vijaya

29-03-2019

Hi Prince,

Bundle is in active state and we are getting expected output from classes on other packages. Its only issue with new java package.

I'm using AEM 6.4 version with SP3 and I've deployed Wknd tutorial source code from below link.

GitHub - Adobe-Marketing-Cloud/aem-guides-wknd: Steps to create a website with Adobe Experience Mana...

Highlighted

Avatar

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281
Gaurav-Behl
MVP

30-03-2019

Could you explain more regarding "Its only issue with new java package."

Is this issue with your custom package that you've created and added into existing pom.xml?

Highlighted

Avatar

Avatar

Prince_Shivhare

Avatar

Prince_Shivhare

Prince_Shivhare

03-04-2019

please check if you have declared this as <sling-model package> in your POM file.

if not please declare it. also if you have created package other than this path com.adobe.aem.guides.wknd.core.*

please include that as well. also, check if your model class or servlet is present in console/component or check in sling resource resolver.

~ Prince