why maven update reset to default modules? AEM 6.5.0

Avatar

Avatar

frankml_ve

Avatar

frankml_ve

frankml_ve

12-09-2019

Hello.

At first of all, I have to say that a barely new working with AEM, so I'm trying to do the WKND tutorial, but when I get to the step 5 (Custom Component) and a update my parent pom.xml and the core module pom.xml, eclipse throw an error on the org.osgi.service.component.propertytypes import and on the org.osgi.service.component.annotations, so i ran maven update from the eclipse IDE and I get all the modules of proyect reset back to defeault state.

Please anybody have this trouble to? its a bug?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

jbrar

Employee

Avatar

jbrar

Employee

jbrar
Employee

16-09-2019

I used eclipse 4.8 and it works fine, Can you try with 4.8 and let me know if you still see the same issue?

You can follow steps at [1] to set up the local environment.

[1] https://docs.adobe.com/content/help/en/experience-manager-learn/foundation/development/set-up-a-loca...

Answers (2)

Answers (2)

Avatar

Avatar

frankml_ve

Avatar

frankml_ve

frankml_ve

16-09-2019

Hello @Jaideeprar, thanks a lot for your answer.

I create the project directly from the eclipse IDE my version of it is the 4.12.0 (the latest), using the archetype 20 and teh maven version is 3.6.1, during the process I get an error that I figure out is a bug, but I dont know who have the bug.

What version of eclipse you use for your test?

Avatar

Avatar

jbrar

Employee

Avatar

jbrar

Employee

jbrar
Employee

14-09-2019

Check if you are using the latest version WKND project at [1]. I have gone through the tutorial myself and did not run into any issues.

You can download the chapter solution from the link below and compare the pom file to check the missing requirements.

Screen Shot 2019-09-14 at 11.43.24 AM.png

[1] WKND Tutorial Overview