Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

When exporting using VLT the behaviour changes for a specific workspace filter when adding another filter

keithbsalmon
Level 2
Level 2

When exporting content from the JCR using VLT with the following:

Command

vlt --credentials XXX:XXX export -v http://localhost:4502/crx / ./src/main/content

filter.xml

<?xml version="1.0" encoding="UTF-8"?>

<workspaceFilter version="1.0">

  <filter root="/apps/gtsp" />

</workspaceFilter>

All goes as expected and using one file as an example this is what gets exported:

../src/main/content/jcr_root/apps/gtsp/components/common/Container/.content.xml

<?xml version="1.0" encoding="UTF-8"?>

<jcr:root xmlns:sling="http://sling.apache.org/jcr/sling/1.0" xmlns:cq="http://www.day.com/jcr/cq/1.0" xmlns:jcr="http://www.jcp.org/jcr/1.0"

    cq:isContainer="true"

    jcr:description="Container to drop components into. Has switches to change background and make it full width."

    jcr:primaryType="cq:Component"

    jcr:title="Container"

    sling:resourceSuperType="wcm/foundation/components/responsivegrid"

    componentGroup="GTSP"/>

However if I add another filter (/conf/gtsp) to the filter.xml as shown below the behaviour for the existing (/apps/gtsp) filter changes

<?xml version="1.0" encoding="UTF-8"?>

<workspaceFilter version="1.0">

  <filter root="/apps/gtsp" />

  <filter root="/conf/gtsp" />

</workspaceFilter>

Using the same file as before this is what now gets exported:

../src/main/content/jcr_root/apps/gtsp/components/common/Container/.content.xml

<?xml version="1.0" encoding="UTF-8"?>

<jcr:root/>

What am I missing here?

0 Replies