WCM core upgrade to 2.9.0 with 6.5.3



Hi Team,


I'm upgrading my core components to 2.9.0, is it mandatory to have 6.5.4 service pack for it?

As per documentation https://github.com/adobe/aem-core-wcm-components 

They mentioned , system requirement as 6.5.4+ , I've 6.5.3 installed and i couldn't find any issue so far with 2.9.0 core component.


Can someone confirm if it's fine to proceed?


Accepted Solutions (1)

Accepted Solutions (1)




Hi @chandeshj240320 


As per their documentation, the system requirement is (Reference https://github.com/adobe/aem-core-wcm-components/blob/master/VERSIONS.md)

Core Components Historical System Requirements:


Core 2.9.0 AEM Java 8, 11


They only mention supporting version for AEM 6.5. So, I would recommend you upgrade your AEM instance to service pack if you want to proceed with the latest core component and want to avoid any unexpected issue.



Arpit Varshney

Answers (1)

Answers (1)




Hi @chandeshj240320 , as per the documentation the Core Components 2.9.0 is compatible with AEM 6.5.4+ version. As mentioned by you that you have deployed the Core Components 2.9.0 on AEM 6.5.3 and you are not facing any issue, but in the future, if you face any issue/if you find any bug, Adobe will not provide support for that because of the recommended version is AEM 6.5.4+. 


So I would recommend using the version AEM 6.5.4 so that in future if you face any issue you can reach out to Adobe support for help.