Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

UTF-8 characters returned from Search and Promote show garbled characters

Avatar

Avatar
Validate 10
Level 3
kishore_polsani
Level 3

Likes

11 likes

Total Posts

77 posts

Correct Reply

7 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 3
kishore_polsani
Level 3

Likes

11 likes

Total Posts

77 posts

Correct Reply

7 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
kishore_polsani
Level 3

08-07-2020

When using Search and Promote integration with AEM, certain UTF-8 characters are returned in results (XML) as garbled characters. Text is visible correctly in Search and Promote data view report with proper UTF-8 encoding.

I have added the charset as UTF-8 in both custom presentation and transport templates. Any idea why the text in XML response is not having proper encoding.

 

TestPresentation.tmpl

<guided-content-type-header content="text/xml; charset=UTF-8" />
<guided-xml-decl charset="UTF-8">

 

TestTransport.tpl

<guided-content-type-header content="text/xml">
<guided-xml-decl charset="1">

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
MVP
Albin_Issac
MVP

Likes

106 likes

Total Posts

119 posts

Correct Reply

33 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile

Avatar
Validate 1
MVP
Albin_Issac
MVP

Likes

106 likes

Total Posts

119 posts

Correct Reply

33 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile
Albin_Issac
MVP

08-07-2020

Try adding sp_cs=UTF-8  parameter to the URL e.g  http://stage-xxxxxx.guided.ss-omtrdc.net/sp_staged=1&sp_q=*&sp_cs=UTF-8

 

Regards

Albin I

www.albinsblog.com

Answers (0)