Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Upgrading from AEM6.0 to AEM6.3

Avatar

Level 4

Hi Team,

I am getting the below error while upgrading the instance from AEM6.0 to AEM6.3.  Siteadmin , damadmin , useradmin is opening with blank screen.

*ERROR* [sling-default-12-Registered Service.3498] org.apache.sling.commons.scheduler.impl.QuartzScheduler Exception during job execution of org.apache.sling.distribution.packaging.impl.ResourceDistributionPackageCleanup@687c2cbf : Can't create child on a synthetic root

java.lang.IllegalArgumentException: Can't create child on a synthetic root

at org.apache.sling.resourceresolver.impl.ResourceResolverImpl.create(ResourceResolverImpl.java:1156)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResourceInternal(ResourceUtil.java:656)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:593)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:561)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResourceInternal(ResourceUtil.java:644)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:593)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:561)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResourceInternal(ResourceUtil.java:644)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:593)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:561)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResourceInternal(ResourceUtil.java:644)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:593)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:561)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResourceInternal(ResourceUtil.java:644)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:593)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:561)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResourceInternal(ResourceUtil.java:644)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:593)

at org.apache.sling.api.resource.ResourceUtil.getOrCreateResource(ResourceUtil.java:561)

at org.apache.sling.distribution.packaging.impl.DistributionPackageUtils.getPackagesRoot(DistributionPackageUtils.java:282)

at org.apache.sling.distribution.packaging.impl.ResourceDistributionPackageBuilder.getPackages(ResourceDistributionPackageBuilder.java:245)

at org.apache.sling.distribution.packaging.impl.ResourceDistributionPackageCleanup.run(ResourceDistributionPackageCleanup.java:61)

at org.apache.sling.commons.scheduler.impl.QuartzJobExecutor.execute(QuartzJobExecutor.java:118)

at org.quartz.core.JobRunShell.run(JobRunShell.java:202)

at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Thanks in advance

Sumit

0 Replies

Avatar

Level 4

Hi Sumit,

I got the same exception with you, do you find the solution for this?

Thanks.

Avatar

Level 10

This is a product bug - this should not be happening - please open a support ticket.

Avatar

Level 2

Hi all,

             i have seen the same exception when there is no proper permission are not to create new node in the specified location. I have added everyone group to root folder. It has solved this exception for me.

Thanks & Regards,

Radhakrishna.

Avatar

Level 2

Hi Sumit,

We are facing same issue while upgrading 6.1 to 6.3. How did you solve this "Can't create child on a synthetic root" issue. Can you please post the solution here.

Thanks

Indrasena Reddy

Avatar

Level 4

Hi indrasena reddyc20610255​,@SumitSinghal  Were you able to resolve this issue? Could you please post the solution here.

Thanks,

Anusha

Avatar

Level 4

Hi ,

Was there a solution to this. I am also facing the same issue.

Avatar

Level 4

Hi ,

I am also facing the same issue. Is there a solution available ?

Avatar

Level 10

If you are following the offiical AEM Docs here- -

Upgrading to AEM 6.3

And something breaks - this is an issue for customer support. You need to report this so the ENG team can fix it. It should be working as per the AEM product docs.

Avatar

Employee

If you have an access to CRXDe -> package manager try to install SP3: AEM 6.3.3.0 Release Notes

In a case when a package manager is not reachable stop AEM, create .../crx-quickstart/install folder, place SP3 zip into it and start AEM. SP3 will be installed while AEM is starting up.