Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Upgrading from AEM 6.0 to 6.3 - Code deployment question

Avatar

Avatar
Validate 1
Level 2
atulp44324524
Level 2

Likes

2 likes

Total Posts

12 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
atulp44324524
Level 2

Likes

2 likes

Total Posts

12 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile
atulp44324524
Level 2

23-03-2017

Hello All,

this is my first post in this forum. At Cisco we are currently using AEM 6.0 and have built a pretty big code around it 🙂 We are planning to upgrade the AEM version to 6.3 and have started a POC.

We have just installed the 6.3 on a sandbox environment and trying to deploy the existing code to it. Some of the bundles are not getting active. There are bunch of errors in the error.log but they are all pretty much same about some version complain. I have pasted a couple of them below. I think we need to change some of the com.day.cq.* jar versions in our pom.xml file but not exactly sure which ones. Can someone please help us out here ?

Thanks

- Atul

23.03.2017 16:56:31.950 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle it.cits.ciscoworkforcecontentservices.wem.cdc-devops.workflows [617]. Reason: {}. Will retry.
org.osgi.framework.BundleException: Unable to resolve it.cits.ciscoworkforcecontentservices.wem.cdc-devops.workflows [617](R 617.0): missing requirement [it.cits.ciscoworkforcecontentservices.wem.cdc-devops.workflows [617](R 617.0)] osgi.wiring.package; (&(osgi.wiring.package=com.cisco.wem.services)(version>=1.35.0)(!(version>=2.0.0))) [caused by: Unable to resolve it.cits.ciscoworkforcecontentservices.wem.cdc-devops.services [608](R 608.0): missing requirement [it.cits.ciscoworkforcecontentservices.wem.cdc-devops.services [608](R 608.0)] osgi.wiring.package; (&(osgi.wiring.package=com.cisco.wem.author.common.services)(version>=1.35.0)(!(version>=2.0.0))) [caused by: Unable to resolve it.cits.ciscoworkforcecontentservices.wem.cdc-devops.authoringcommonutils [530](R 530.0): missing requirement [it.cits.ciscoworkforcecontentservices.wem.cdc-devops.authoringcommonutils [530](R 530.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.replication)(version>=5.5.0)(!(version>=6.0.0)))]] Unresolved requirements: [[it.cits.ciscoworkforcecontentservices.wem.cdc-devops.workflows [617](R 617.0)] osgi.wiring.package; (&(osgi.wiring.package=com.cisco.wem.services)(version>=1.35.0)(!(version>=2.0.0)))]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
        at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)
        at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)
        at org.apache.sling.installer.core.impl.tasks.BundleStartTask.execute(BundleStartTask.java:97)
        at org.apache.sling.installer.core.impl.OsgiInstallerImpl.doExecuteTasks(OsgiInstallerImpl.java:894)
        at org.apache.sling.installer.core.impl.OsgiInstallerImpl.executeTasks(OsgiInstallerImpl.java:729)
        at org.apache.sling.installer.core.impl.OsgiInstallerImpl.run(OsgiInstallerImpl.java:286)
        at java.lang.Thread.run(Thread.java:745)
23.03.2017 16:56:32.018 *INFO* [OsgiInstallerImpl] org.apache.sling.installer.core.impl.tasks.BundleStartTask Could not start bundle it.cits.ciscoworkforcecontentservices.wem.cdc-devops.authoringcommonutils [530]. Reason: {}. Will retry.
org.osgi.framework.BundleException: Unable to resolve it.cits.ciscoworkforcecontentservices.wem.cdc-devops.authoringcommonutils [530](R 530.0): missing requirement [it.cits.ciscoworkforcecontentservices.wem.cdc-devops.authoringcommonutils [530](R 530.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.replication)(version>=5.5.0)(!(version>=6.0.0))) Unresolved requirements: [[it.cits.ciscoworkforcecontentservices.wem.cdc-devops.authoringcommonutils [530](R 530.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.replication)(version>=5.5.0)(!(version>=6.0.0)))]
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4112)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
        at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)
        at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)

View Entire Topic

Avatar

Avatar
Validate 10
Level 4
sandeepm744005
Level 4

Likes

19 likes

Total Posts

127 posts

Correct Reply

13 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 4
sandeepm744005
Level 4

Likes

19 likes

Total Posts

127 posts

Correct Reply

13 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
sandeepm744005
Level 4

24-03-2017

Can someone confirm from Adobe, is AEM6.3 available to use ? i was under the impression that only beta is available and actual version would be released in May.