Unresolved dependency after installing service pack 6.4.8

Avatar

Avatar

ruchim71073425

Avatar

ruchim71073425

ruchim71073425

09-07-2020

Hello,

 

After installing AEM 6.4.8 on our dev instance, we are seeing the following issue:

stdout.log:05.07.2020 23:36:22.579 ERROR [FelixStartLevel] ERROR: Bundle '176' Error starting launchpad:resources/install/0/aemds-guide-core-impl-5.0.118.jar (org.osgi.framework.BundleException: Unable to resolve com.adobe.aemds.guide.aemds-guide-core-impl [176](R 176.0): missing requirement [com.adobe.aemds.guide.aemds-guide-core-impl [176](R 176.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemfd.expeditor.service)(version>=2.10.0)(!(version>=3.0.0))) Unresolved requirements: [[com.adobe.aemds.guide.aemds-guide-core-impl [176](R 176.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemfd.expeditor.service)(version>=2.10.0)(!(version>=3.0.0)))])
stdout.log:org.osgi.framework.BundleException: Unable to resolve com.adobe.aemds.guide.aemds-guide-core-impl [176](R 176.0): missing requirement [com.adobe.aemds.guide.aemds-guide-core-impl [176](R 176.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemfd.expeditor.service)(version>=2.10.0)(!(version>=3.0.0))) Unresolved requirements: [[com.adobe.aemds.guide.aemds-guide-core-impl [176](R 176.0)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.aemfd.expeditor.service)(version>=2.10.0)(!(version>=3.0.0)))]

 

I can confirm that the bundle - Expression Editor Utils Bundle (com.adobe.aemfd.expeditor.aemfd-expeditor-utils-bundle) is missing in that environment.

But I am not sure how to resolve this issue.

 

I had done the same SP installation in my local and faced no such issue.

 

Any help would be appreciated.

 

Thanks

Ruchi

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

ArpitVarshney

MVP

Avatar

ArpitVarshney

MVP

ArpitVarshney
MVP

09-07-2020

Hi @ruchim71073425 

Could you please verify:

  • If you have updated the custom aem code to use aem 6.4.8 uber jar? You have to update pom uber version like below:

                       <dependency>
                             <groupId>com.adobe.aem</groupId>
                            <artifactId>uber-jar</artifactId>
                            <version>6.4.8</version>
                            <scope>provided</scope>
                        </dependency>

  • Also, the mentioned package com.adobe.aemds.guide.aemds-guide-core-impl is related to AEM forms package which might be missing in your local instance. You need to verify if the AEM version 6.4.8 support different version of the package which might be located here https://helpx.adobe.com/in/aem-forms/kb/aem-forms-releases.html

Regards,

Arpit Varshney

Answers (0)