Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

[AEM Gems Webinar] Accelerating Experience Manager as a Cloud Service development with Rapid Development Environments

Unresolved compilation errors when replicating to publish instances, only on some servers

Avatar

Level 4

We have two sets of publish environments being replicated to from one author server:

First Set: 8 servers - CQ 5.6.1, JDK 1.7.0_72
Second Set: 4 servers - CQ 5.6.1, JDK 1.6.0_33

We've started to run into an issue the last few months where random servers of the first set will not correctly run our application's bundle after it has been replicated from author. The bundle appears to start normally but when a JSP tries to use certain classes the bundle will throw "unresolved compilation error" messages, listing "XCLASSX cannot be resolved to a type". Each time we run into this the classes are different - sometimes our custom classes in the bundle and sometimes default CQ library classes that we're referencing. This will happen randomly to 1- 5 out of 8 servers and no amount of restarting the publish instances will resolve the issue. The only way we've found so far to get around it is to bring down one of the working instances, copy/overwrite one of the broken servers, and then bring them back up. It will then work as expected for weeks at a time. Has anyone else run into this? From looking around i'd guess it has something to do with JDK versions?

We're using eclipse/maven to build the bundle and it is being compiled with JDK 1.7.0_80. The servers running JDK 1.6 have never had a problem

Thanks

3 Replies

Avatar

Level 10

This looks like a JDK issue. My recommendation is to open a ticket and see if support has a fix for this. 

https://helpx.adobe.com/marketing-cloud/contact-support.html

Avatar

Administrator

Hi 

As per the documentation, 1.7 is the recommended one.

Documentation Link:- https://docs.adobe.com/docs/en/cq/5-6-1/deploying/technical_requirements.html

//To install AEM you need:

    The Java Runtime Environment (JRE). Version 1.7 is preferred. See Java Virtual Machines for details.

But you are facing problem in 1.7 only.  What exactly full error message you are getting ??

Please create a support case at :- https://helpx.adobe.com/marketing-cloud/contact-support.html

~kautuk

Avatar

Administrator

Hi 

As per the documentation, 1.7 is the recommended one.

Documentation Link:- https://docs.adobe.com/docs/en/cq/5-6-1/deploying/technical_requirements.html

//To install AEM you need:

    The Java Runtime Environment (JRE). Version 1.7 is preferred. See Java Virtual Machines for details.

But you are facing problem in 1.7 only.  What exactly full error message you are getting ??

Please create a support case at :- https://helpx.adobe.com/marketing-cloud/contact-support.html

~kautuk