Unable to save the data while using the extended Jouranl Component.

Avatar

Avatar
Give Back
Level 1
adarsh200
Level 1

Like

1 like

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Boost 1
View profile

Avatar
Give Back
Level 1
adarsh200
Level 1

Like

1 like

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Boost 1
View profile
adarsh200
Level 1

05-10-2018

Hi,

I have followed every step given in the following repo GitHub - Adobe-Marketing-Cloud/aem-scf-sample-components-extension: Sample package for AEM Social Co...

I have added the subtitle property to "com.adobe.cq.social.journal.client.endpoints.impl.JournalOperationsService" and created a page using the given template and tried to add the extended journal component and clicked on New Article and tried to enter some content and clicked on publish immediately. But after I click on Publish it's taking me to the same page and no content is being published. And  I checked if the UGC is stored under /content/usergenerated/asi/jcr/content.

Where as the other components are working fine. I have added the required client libraries. Can anyone help me what am I missing?

1589583_pastedImage_8.png

And now, when I clicked on publish nothing is being saved.

1589584_pastedImage_9.png

1589600_pastedImage_10.png

1589601_pastedImage_11.png

Replies

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

05-10-2018

We asked the team to help here.

Avatar

Avatar
Give Back
Level 1
adarsh200
Level 1

Like

1 like

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Boost 1
View profile

Avatar
Give Back
Level 1
adarsh200
Level 1

Like

1 like

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Give Back
Ignite 1
Boost 1
View profile
adarsh200
Level 1

18-10-2018

looks like JS folder under etc/designs/acme/site/js is causing issue. Unable to find out the reason. Once I delete the JS folder it's working fine but now the ideation component is not working.