Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Unable to launch primay AEM instance in primary run mode for cold standby environment.

Avatar

Level 2

Hi,

I'm currently working on installing author instance with cold standby instance.

At first, I have installed primary AEM 6.3 instance as per document [0] below.

The AEM instance just installed, has been configured with datastore(filestore) storage.

Next, I restarted the primary AEM instance with primary run mode with below three PID config files.

1) org.apache.jackrabbit.oak.plugins.blob.datastore.FileDataStore.config

org.apache.sling.installer.configuration.persist=B"false"

path="/home/joseph/SHARED_DATASTORE"

minRecordLength=I"1024"

maxCachedBinarySize=I"1048576"

cacheSizeInMB=I"1024"

cacheSize=L"68719476736"

cachePath="./crx-quickstart/repository/cache"

2) org.apache.jackrabbit.oak.segment.SegmentNodeStoreService.config

org.apache.sling.installer.configuration.persist=B"false"

repository.home="./crx-quickstart/repository"

customBlobStore=B"true"

standby=B"false"

tarmk.size=I"256"

3) org.apache.jackrabbit.oak.segment.standby.store.StandbyStoreService.config

org.apache.sling.installer.configuration.persist=B"false"

mode="primary"

port=I"8023"

However, right after start the primary instance with primary run mode, it won't properly get started.

I see many of errors tells that missing repository service.

Please see error message below [1]

I'm not able to see AEM web UI due to the error.

I'm not sure if I did something wrong.

Please advise. Any comment or advice will be welcome.

Thanks!!

[0] : How to Run AEM with TarMK Cold Standby

[1] :

13.07.2017 13:36:49.220 *INFO* [FelixDispatchQueue] org.apache.felix.framework Service [Apache Sling Startup Service,3390, [org.apache.sling.launchpad.api.StartupService]] ServiceEvent REGISTERED

13.07.2017 13:36:49.223 *INFO* [FelixDispatchQueue] org.apache.felix.framework FrameworkEvent STARTED

13.07.2017 13:36:49.957 *ERROR* [qtp315656710-600] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: AuthenticationSupport service missing. Cannot authenticate request.

13.07.2017 13:36:49.958 *ERROR* [qtp315656710-600] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: Possible reason is missing Repository service. Check AuthenticationSupport dependencies.

13.07.2017 13:36:51.965 *ERROR* [qtp315656710-652] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: AuthenticationSupport service missing. Cannot authenticate request.

13.07.2017 13:36:51.965 *ERROR* [qtp315656710-652] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: Possible reason is missing Repository service. Check AuthenticationSupport dependencies.

13.07.2017 13:36:53.997 *ERROR* [qtp315656710-600] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: AuthenticationSupport service missing. Cannot authenticate request.

13.07.2017 13:36:53.997 *ERROR* [qtp315656710-600] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: Possible reason is missing Repository service. Check AuthenticationSupport dependencies.

13.07.2017 13:36:56.007 *ERROR* [qtp315656710-652] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: AuthenticationSupport service missing. Cannot authenticate request.

1 Accepted Solution

Avatar

Correct answer by
Level 7

Hi JosephKwon,

With above configurations which you have provided,I have tested in my local Cent OS Linux.

Primary author is working as expected with a shared datastore.

If you are still facing the issue,Once again try a new setup.

Thanks,

Techaspect Solutions.

View solution in original post

0 Replies

Avatar

Level 2

Thanks kautukshni,

I've succeed on Windows 7 with above conf.(just slightly changed path scheme for Windows) files but failed on CentOS(or Redhat Linux).

I believe this should work on Linux as well.

Thanks,

Joseph

Avatar

Level 2

This is for information only.

The configuration files for scratch installation -> http://125.128.34.143:10080/install.initial.tar

The configuration files for initail primary run mode start -> http://125.128.34.143:10080/install.pri.fail.tar

Thanks

Joseph

Avatar

Level 2

Thanks, smacdonald.

However I should use shared datastore for cold standby in order to minimize disk space usage for sync operation.

So I can't use default segmentstore for data storage but need to use datastore(filestore).

The article which you commented does not cover datastore storage.

Thanks anyway,

Joseph

Avatar

Correct answer by
Level 7

Hi JosephKwon,

With above configurations which you have provided,I have tested in my local Cent OS Linux.

Primary author is working as expected with a shared datastore.

If you are still facing the issue,Once again try a new setup.

Thanks,

Techaspect Solutions.

Avatar

Level 2

Hi Techaspect Solutions,

As you commented, I've tried again then succeeded.

I'm not sure what was wrong in my testing environment.

I sincerely appreciate your great effort in supporting me.

Great thanks.

Regards,

Joseph

Avatar

Level 2

Dear all,

I'm not sure what made wrong result but I've succeeded it.

This is looks came from my mistake.

I really appreciate all effort in supporting me.

It was really great.

Thank you all

Joseph