Unable to Deploy over HTTPS end point

Avatar

Avatar

Mayukh007

Avatar

Mayukh007

Mayukh007

29-09-2020

HI,

 

I am trying to deploy ui.apps, core.jar artifacts into AEM Author and Pub using Jenkins job. Previously we used to connect over HTTP using ip and port to deploy package. This job does Build > store to artifactory > then take the package and do deploy (CI  & CD).

Commands were:

authDeployCommand:mvn -q -f pom.xml clean install-PautoInstallPackage  -Dcrx.host=${AEM_AUTHOR_CREDENTIALS_USR} -Dcrx.password=${AEM_ADMIN_CREDENTIALS_PSW} -Dcrx.port=4502 -e
pubDeployCommand:mvn -q -f pom.xml clean install -PautoInstallPackage -Dcrx.host=${AEM_PUBLISHER_CREDENTIALS_USR} -Dcrx.password=${AEM_ADMIN_CREDENTIALS_PSW} -Dcrx.port=4503 -e

 Here ${AEM_AUTHOR_CREDENTIALS_USR} for example is ip of AEM Auth.

But now we received HTTPS end points and URLs and would like to use that to deploy and block off HTTP connection.

 

So I updated the maven commands to this:

authDeployCommand:mvn -q -f pom.xml clean install -PautoInstallPackage -Dcrx.host=auth.adobecqms.net -Dcrx.password=${AEM_ADMIN_CREDENTIALS_PSW} -Dcrx.port=443 -e
pubDeployCommand:mvn -q -f pom.xml clean install -PautoInstallPackage -Dcrx.host=pub.adobecqms.net -Dcrx.password=${AEM_ADMIN_CREDENTIALS_PSW} -Dcrx.port=443 -e

But I am getting error when doing Deploy as unknown host / can not connect over http...

Am I missing something... ?

Accepted Solutions (0)

Answers (1)

Answers (1)

Avatar

Avatar

Singaiah_Chintalapudi

MVP

Avatar

Singaiah_Chintalapudi

MVP

Singaiah_Chintalapudi
MVP

29-09-2020

The maven architype injects the http into the pom configs. You can create a new profile with https. Please below discussion for more info:

 

https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/deploying-packages-to-a-se...

 

Thanks,

Singaiah