Unable to create project from archetype [com.adobe.granite.archetypes:aem-project-archetype:19 -> https://repo.adobe.com/nexus/content/groups/public] in eclipse

amanagarwal21 14-06-2019

Hi All,

I am getting the following err., when trying to create AEM project through Eclipse. Kindly, share details what could be causing this.

Unable to create project from archetype [com.adobe.granite.archetypes:aem-project-archetype:19 -> https://repo.adobe.com/nexus/content/groups/public]

1772153_pastedImage_7.png

PS: I am aware of an alternate way to create AEM project through MVN Archetype. Just want to try it through Eclipse as well.

Regards,

Aman

Mark Solution

Are these answers useful?
Help other community members by marking useful answers as accepted.

Accepted Solutions (0)

Answers (4)

Answers (4)

tonyruban04 29-02-2020

Hi @amanagarwal21 ,

 

1. Check if all the values are configured under Advanced options in the previous window, configure archetype properties.

Screenshot 2020-03-01 at 12.38.23 PM.png

2. If they are all configured then maybe the adobe repo is not properly referenced.

The solution for this is to add the adobe-public profile to your Maven settings.xml file in order to automatically add repo.adobe.com to the maven build process. Refer https://docs.adobe.com/content/help/en/experience-manager-learn/foundation/development/set-up-a-loca...