Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Unable to create project from archetype [com.adobe.granite.archetypes:aem-project-archetype:20 -> https://repo.adobe.com/nexus/content/groups/public]

Avatar

Avatar
Validate 1
Level 1
ajaykp
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
ajaykp
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
ajaykp
Level 1

08-09-2019

Unable to create a new AEM project in either eclipse or Maven command line:

Unable to create project from archetype [com.adobe.granite.archetypes:aem-project-archetype:20 -> https://repo.adobe.com/nexus/content/groups/public]

Please let me know when the Adobe server is available.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back
Level 1
red_devil
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

1 solution
Top badges earned
Give Back
Affirm 1
View profile

Avatar
Give Back
Level 1
red_devil
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

1 solution
Top badges earned
Give Back
Affirm 1
View profile
red_devil
Level 1

29-02-2020

Hi @ajaykp ,

 

1. Check if all the values are configured under Advanced options in the previous window, configure archetype properties.

Screenshot 2020-03-01 at 12.38.23 PM.png

2. If they are all configured then maybe the adobe repo is not properly referenced.

The solution for this is to add the adobe-public profile to your Maven settings.xml file in order to automatically add repo.adobe.com to the maven build process. Refer https://docs.adobe.com/content/help/en/experience-manager-learn/foundation/development/set-up-a-loca...

Answers (2)

Answers (2)

Avatar

Avatar
Validate 10
Level 3
何塞
Level 3

Likes

12 likes

Total Posts

48 posts

Correct Reply

1 solution
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 10
View profile

Avatar
Validate 10
Level 3
何塞
Level 3

Likes

12 likes

Total Posts

48 posts

Correct Reply

1 solution
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 10
View profile
何塞
Level 3

08-09-2019

I had the same issue and here is what I did to get around it:

Eclipse version:

Eclipse IDE for Enterprise Java Developers.

Version: 2019-06 (4.12.0)

Build id: 20190614-1200

Steps:

1) After you click finish and get the error, go back to the "Configure Archetype Properties" menu.

2) Click on Advanced and notice how about half of the properties are empty.

3) Fill in the missing properties and click next.

4) Even though the error will still be there, click Finish again and it will work.

Good luck!

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,356 likes

Total Posts

3,227 posts

Correct Reply

917 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,356 likes

Total Posts

3,227 posts

Correct Reply

917 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

08-09-2019

can you check? it is available.

what other issues are you facing? I created a project with archtype 20, let me know if you face any issue.