Unable to create content fragment model in AEM 6.5 throws server error

nandini559

28-05-2020

I'm unable to create content fragment model in one of our environments even when i'm logged in with admin. It throws server error.

Attaching screenshot and stack trace in the comments below.

 

nandini559_0-1590658460089.png

 

22.05.2020 04:23:03.064 *ERROR* [10.30.60.206 [1590139383053] POST /mnt/overlay/dam/cfm/models/console/content/createmodelwizard.html/conf/dam/cfm/models/console/content/createmodelwizard/_jcr_content HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException

java.lang.NullPointerException: null

        at org.apache.jsp.apps.cq.Page.POST_jsp._jspService(POST_jsp.java:208)

        at org.apache.sling.scripting.jsp.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70) [org.apache.sling.scripting.jsp:2.3.6]

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:725) [org.apache.felix.http.servlet-api:1.1.2]

        at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:502) [org.apache.sling.scripting.jsp:2.3.6]

        at org.apache.sling.scripting.jsp.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:449) [org.apache.sling.scripting.jsp:2.3.6]

        at org.apache.sling.scripting.jsp.JspScriptEngineFactory.callJsp(JspScriptEngineFactory.java:339) [org.apache.sling.scripting.jsp:2.3.6]

View Entire Topic

khamat_bn

04-06-2020

@nandini559 ,

Two Things

1) If you have installed the Service pack recently-There might possibilities that you core package affected and its not Active state. Please verify it and try to restart the AEM. 

2) If the issue persist, then uninstall the SP and install it again with other browser except chrome and see all bundles are getting Active state or not.

Once your all bundles are active then you good to go.

Let us know if its works for you.

 

Happy Coding 

~BK 🙂