Unable to add components to page

pallavis8124480

19-11-2018

Hi ,

I am unable to add component to page even the components are allowed in design mode. The add component symbol(+ symbol) itself is not appearing . I can see only experience fragment symbol.

1625621_pastedImage_0.png

Also please see the screenshot  ,it is generating some error in the console log.

NOTE : I am trying to add the components using proper privileges but still no luck.

Please let me know if any idea on this issue.

Thanks,

Pallavi

Answers (10)

Answers (10)

pallavis8124480

20-11-2018

@veena_07 & smacdonald2008​ :

I was able to get some logs .Please find the below logs :

js uses the deprecated asynchronous API provided by the 'granite' namespace. Please refactor the script to use the synchronous API provided by the org.apache.sling.scripting.javascript bundle.

20.11.2018 00:37:02.863 *WARN* [10.80.184.201 [1542692222347] GET /content/era/leverage.html HTTP/1.1] org.apache.sling.scripting.sightly.js.impl.jsapi.ProxyAsyncScriptableFactory Script /libs/wcm/foundation/components/page/headlibs.js uses the deprecated asynchronous API provided by the 'granite' namespace. Please refactor the script to use the synchronous API provided by the org.apache.sling.scripting.javascript bundle.

org.apache.sling.scripting.sightly.js.impl.jsapi.ProxyAsyncScriptableFactory Script /libs/wcm/foundation/components/page/body.js uses the deprecated asynchronous API provided by the 'granite' namespace. Please refactor the script to use the synchronous API provided by the org.apache.sling.scripting.javascript bundle.

Veena_Vikram

MVP

20-11-2018

There should be some issue with the env then . Is all the bundles in system console active ? Not your project alone, but almost all bundles should be in active state.

pallavis8124480

19-11-2018

smacdonald2008​ :

Thanks for the link . Yes we are using static templates.

We are seeing the following error :
1625642_pastedImage_0.png

error in indexed-db adapter !


This issue is observed in one of environment where we dont have the sample content.

smacdonald2008

19-11-2018

Design mode works with projects that use static templates. Projects built wiht Editable Templates use policies - not Design mode to specify what components can be used on a page. If you are not familar with Editabel Templates - see:

Scott's Digital Community: Guided Journey for Experience Manager on Editable Templates

Now for your problem - are you seeing error messages in the log? Can you add components to the We Retail site?