Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Troubleshooting a Client Library loading Failure

Avatar

Avatar
Validate 1
Level 1
AEMUserFromPlano
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
AEMUserFromPlano
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
AEMUserFromPlano
Level 1

22-03-2020

Hello 

AEM 6.5 --> Browsed couple of places and tutorials. Did not find a way to troubleshoot. So thought of asking that question here. When you have a line that says

<sly data-sly-use.clientLib="/libs/granite/slightly/templates/clientlib.html" data-sly-call="${clientLib.js @ categories='we.train.all'}"/> , I understand the js and css should be in a folder of type cq:ClientLibraryFolder and categories should have we.train.all and this folder can be anywhere, but ideally in /apps/ folder. (I am referring to tutorials that were probably written prior to 6.5 version and that says to put it in /etc/designs/)

 

Question, using developer tools, if the css doesnot get loaded, how do I troubleshoot to figure out, where I have gone wrong

 

Thanks

View Entire Topic

Avatar

Avatar
Seeker
MVP
Suraj_Kamdi
MVP

Likes

146 likes

Total Posts

157 posts

Correct Reply

41 solutions
Top badges earned
Seeker
Bedrock
Engage 1
Springboard
Validate 1
View profile

Avatar
Seeker
MVP
Suraj_Kamdi
MVP

Likes

146 likes

Total Posts

157 posts

Correct Reply

41 solutions
Top badges earned
Seeker
Bedrock
Engage 1
Springboard
Validate 1
View profile
Suraj_Kamdi
MVP

22-03-2020

@AEMUserFromPlano 

First, check whether clientlib folder has css.txt and js.txt files.