Translated pages showing Wrong Special Characters in page properties

Avatar

Avatar

annyreddy

Avatar

annyreddy

annyreddy

26-01-2021

 

 

Hi All,

 

I am facing issues with translated content after coming back from Translated services, AEM is showing content as mentioned below screenshot.

 

We are creating pages in language master and sending them for translations to translate the content. Once the content pages are back from translation servers, in AEM  page properties showing below.

Please help me on how to resolve this issue.

translationCapture.png

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

BrianKasingli

MVP

Avatar

BrianKasingli

MVP

BrianKasingli
MVP

27-01-2021

annyreddy, you might need your translator to NOT encode special symbols and characters, as your example shows, the Granite UI dialogues will not decode the ended.

Once your data is written in AEM with regular symbols and characters, Making sure your pages are encoded in UTF-8 , your symbols and special characters should be played property to the end uses. If you cant do this, then maybe you would probably need to create something custom to run when translations are written into AEM; Decode all the ended. Checkout this tool here for encoding/decoding special symbols and characters, https://www.web2generators.com/html-based-tools/online-html-entities-encoder-and-decoder

 

<!DOCTYPE html>
<html lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>

 

Answers (0)