Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Throwing 404 when opening a page from inbox

Avatar

Level 3

To make little easy , added all the steps what I had followed and resulting in 404 error while opening the page.

  1. Created the new project "Legal Projects".
  2. Created a new user group "legal_group", and added following groups to that "Authors" and "workflow-users". 
  3. Added the legal_group as owners to the project "Legal Projects".
  4. Created the sample task for testing, for content "/content/campaigns/geometrixx-outdoors/article".
  5.  In Inbox, select the task item and click on open button.
  6.  It should open the page but it is throwing 404 error.

Am sure that there is some missing in permissions, please let me know what is going wrong?

Thanks in advance

0 Replies

Avatar

Level 7

have you tried this with admin user to be sure that this is a user permission issue?

Avatar

Administrator

Hi 

Please check the error.log  to further debug this issue. 

PS: As mentioned by Tuhin, try admin login.

Thanks and Regards

Kautuk Sahni

Avatar

Level 3

Thanks for the reply, Yeah I checked the error logs there are no exceptions or errors. I tried with admin too (sorry didn't mention in my earlier post), same 404 error . This is happening only with Task, with Workitem it is good (opening the page).

My assumption is wrong, this is not be the permission issue, not sure what is causing the issue.

Avatar

Level 10

Looks like a permission issue - try giving that group all permissions (same as admin) and lets see if that works,. 

Avatar

Level 3

I tried that , gave the group administrators and  tried with admin account too, not worked. This is happening only with Task, with Workitem it is good (opening the page).

Avatar

Level 3

Tried inspecting the elements in Inbox, found the blow links, it is just trying to open the page using the API CQ.shared.Util.open(). First one is Task not working and second one is workitem it is working . 

  1. <a href="javascript:CQ.shared.Util.open('/libs/cq/workflow/content/inbox/list.loadPayloadUrl?taskId=/content/projects/20160330/legal_project/jcr:content/tasks/2016-04-06/fhgfdhdfh');void(0);">Credit Cards</a>
  2. <a href="javascript:CQ.shared.Util.open('/etc/workflow/instances/server0/2016-03-31/model_905552414779746/workItems/node2_etc_workflow_instances_server0_2016-03-31_model_905552414779746.loadPayloadUrl');void(0);">BANKING</a>

Is there any thing I am missing?

Avatar

Level 2

Has this issue been resolved ?? I am facing the same issue

Thanks,

Mahesh