Text Component and Internal Link issue

victor_toledo_3

10-04-2019

Hi all,

I have a strange issue with the text component (core/wcm/components/text/v1/text) and a link to an internal page. When I add a link to the internal content, the host name is added to the link and saved in the repository, obviously causing a problem when publishing the page, since the link points to the author.

i'm working with AEM 6.3.0.0, fresh instance (i started the server on port 4505) and We.Retail site

Let me try to explain you the issue with some pics

adding_text_component.png

Then i'm trying to add a text with hyperlink to internal content

creating-hyperlink.pngselecting-internal-content.png

In the image you can see the internal path is correct without hostname

applying-change.png

But when i apply the changes and debug the code

debugging-code1.png

the variable url has the correct value but the when the code save the attributes and get the href value from the child node the hostname is added

debugging-code2.png

And that is the value that is saved to the repository as you can see in the next image

crxde.png

And then when i published that page, obviously the link is pointing to author. So i dont know the why text component (or jquery, or javascipt) is adding the hostname to the url.

Now, if I update the value of the existing link, everything works fine because another javascript flow is executed

any help will be welcome

Thanks in advance

Accepted Solutions (1)

Accepted Solutions (1)

victor_toledo_3

11-04-2019

Hi all, i found the issue and the solution,

I was testing in aem 6.3.3 and the problem does not occur.

Then, I realized that the problem was in 6.3, comparing the js I see that it has been solved sometime between 6.3 and 6.3.3.

AEM 6.3.0.0

Screen Shot 2019-04-11 at 10.19.52.png

AEM 6.3.3.0

Screen Shot 2019-04-11 at 10.20.05.png

So the solution is to update the instance.

Thanks to all

Answers (5)

Answers (5)

jbrar

Employee

10-04-2019

Tried using we-retail Text component and it does not add the hostname:

Screen Shot 2019-04-10 at 7.29.42 PM.png

Have you customized the component? If not, try comparing linkchecker/sling mapping configuration.