strange behavior while starting publish instance

Avatar

Avatar
Give Back 3
Level 2
aemanonymous
Level 2

Likes

10 likes

Total Posts

55 posts

Correct reply

2 solutions
Top badges earned
Give Back 3
Give Back
Ignite 1
Validate 10
Validate 1
View profile

Avatar
Give Back 3
Level 2
aemanonymous
Level 2

Likes

10 likes

Total Posts

55 posts

Correct reply

2 solutions
Top badges earned
Give Back 3
Give Back
Ignite 1
Validate 10
Validate 1
View profile
aemanonymous
Level 2

01-11-2016

I have tried the following 2 ways of starting up the AEM 6.2 publish instance on my local machine after unpacking using -unpack parameter on the jar file.

1. java -jar aem-publish-p4503.jar -r nosamplecontent  (publish run mode picked up from file name)

2. java -jar aem-quickstart-6.2.0.jar -r publish nosamplecontent -p4503  (publish run mode picked up from -r parameter)

 

The problem is with accessing the felix console (http://localhost:4503/system/console) without being logged in initially.

  • In the 1st case, it prompts with the login page. I can access the Felix console by entering details.

 

  • However in the 2nd method, it gives a 

            HTTP ERROR: 500

            Problem accessing /system/console. Reason:

            org.apache.sling.api.auth.NoAuthenticationHandlerException

 

            Here I'll have to first log in to CRX DE lite (http://localhost:4503/crx/de). Login here and then access the Felix console. 

 

Could someone please share some thoughts on this?

View Entire Topic

Avatar

Avatar
Boost 50
Level 10
Sham_HC
Level 10

Likes

161 likes

Total Posts

2,114 posts

Correct reply

1,204 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 100
View profile

Avatar
Boost 50
Level 10
Sham_HC
Level 10

Likes

161 likes

Total Posts

2,114 posts

Correct reply

1,204 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 100
View profile
Sham_HC
Level 10

11-11-2016

yes.