Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Static Agent not generating renditions

mohanb
Level 4
Level 4

Hi

i have configured static agent on author instance. when i publish images, static agent is not generating all the renditions for image published. Is this bug in product or some configuration to be done on static agent to include renditions in publishing queue?

Also i see that all my renditions get queued and wont get processed for long time.

3 Replies
kautuk_sahni
Employee
Employee

Hi 

Just for a reference:- http://stackoverflow.com/questions/31736329/configuring-static-replication-agent-in-aem6-1-author

//

Have you set the rules for your content branch ? Static agent configuration allows you to define the rules on the 2nd tab (Rules).

By default only sample Geometrixx websites are configured

/content/geo* ${path}.html?wcmmode=preview /content/dam* ${path} /content/geo* /content/geometrixx/en.topnav.html /etc/designs/* ${path}

Make sure to add /etc/designs/* ${path}

~kautuk

mohanb
Level 4
Level 4

I have set the rules. When i publish an image asset static agent will generate the image on disk but renditions associated with that image is not getting generated.

When i publish an image it will create aaaa.jpg file on disk but renditions are trying to create a folder with same name and it's failing there.

gregt65506620
Level 2
Level 2

We have this same issue. We need to be able to set a rule to configure the static replication to skip the base image (image.jpg) and instead replicate all of the renditions (image.jpg/_jcr_content/renditions/*)