SPA React not displaying Custom Components

Avatar

Avatar

dexm32937298

Avatar

dexm32937298

dexm32937298

22-08-2019

I have spent a ton of time and combed through the docs to figure out this. My custom built react component is not displaying in the editor, ever. It is showing up on the http://localhost:4502/content/wknd-events/react.model.json and in the CXR/DE. Feel like I have tried everything and I am not seeing any resources for debugging this/ a workaround.  The custom-built components also do not render in ANY AEM instance but if I pull up the local build (localhost:3000) all of the items that I did add appear.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

dexm32937298

Avatar

dexm32937298

dexm32937298

29-08-2019

That helps a little with understanding the pathing that it is taking but Still nothing is working. All of the Data is in the JCR and since Adobes Docs are straight garbage when it comes to this I am not able to find anything.

Answers (9)

Answers (9)

Avatar

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281
Gaurav-Behl
MVP

28-08-2019

Not sure if you have already gone through this doc --  SPA Editor Overview

This diagram explains that if you don't rely on existing/OOB core components/Sling Models/Sling Model Exporters and build custom components then you would need to wire each entity in a correct way either using OOB models/exporters or otherwise with custom implementations.

HTH

page_editor_spa_authoringmediator-2

Avatar

Avatar

dexm32937298

Avatar

dexm32937298

dexm32937298

28-08-2019

Example=> jump straight to exporter, no documentation of where or how this is hooked up. 3rd Video starts with "HTL script that we showed in the last video" when there is no script. To be honest I'm just super disappointed in the little that I can find to help me out.

Avatar

Avatar

dexm32937298

Avatar

dexm32937298

dexm32937298

28-08-2019

Thanks, That doesn't appear to be the issue but then again the docs are garbage, and the videos are not showing anything.

Avatar

Avatar

Vish_dhaliwal

Employee

Avatar

Vish_dhaliwal

Employee

Vish_dhaliwal
Employee

26-08-2019

Avatar

Avatar

dexm32937298

Avatar

dexm32937298

dexm32937298

26-08-2019

Confused on the Sling Model Exporter, what is that?

Avatar

Avatar

SammyK267

Avatar

SammyK267

SammyK267

23-08-2019

Did you make sure to create the Sling Model Exporter for your custom component?

Avatar

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281
Gaurav-Behl
MVP

23-08-2019

I can't pinpoint any issue unless I go through the code. I can try if you're willing to share the minimal code package.

Avatar

Avatar

dexm32937298

Avatar

dexm32937298

dexm32937298

22-08-2019

I have gone through that walkthrough and the one that uses we-journal. On the most simple leve I have just tried to build a text component from the ground up changing names slightly to just follow my trail. Using AEM 6.5.

Avatar

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281
Gaurav-Behl
MVP

22-08-2019

Do you mean to say that you have followed Adobe Experience Manager Help | Getting Started with React and AEM SPA Editor  and same is working fine but your own custom component in AEM?

Could you share more details about that component(s) and what version/SP of AEM do you use?