SPA does not work on publish instances

Avatar

Avatar
Give Back
Level 1
siddupatil
Level 1

Likes

0 likes

Total Posts

8 posts

Correct reply

1 solution
Top badges earned
Give Back
Validate 1
Affirm 1
View profile

Avatar
Give Back
Level 1
siddupatil
Level 1

Likes

0 likes

Total Posts

8 posts

Correct reply

1 solution
Top badges earned
Give Back
Validate 1
Affirm 1
View profile
siddupatil
Level 1

21-02-2021

We are using Angular AEM SPA Pages in our project. AEM SPA pages are working fine in author/preview and view as publish mode. But it is not working in publish instance. I can see json being fetched correctly. On debugging I noticed that jquery clienlib is not loading in publish instance for SPA pages.Also same code base/clientlib is working fine in author instance.

 

SCREENSHOT - Publish page console error 

siddupatil_0-1613975391978.png

 

Any help will be appreciated. Thanks.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Springboard
Level 7
KiranVedantam1992
Level 7

Likes

195 likes

Total Posts

213 posts

Correct reply

60 solutions
Top badges earned
Springboard
Give Back 5
Ignite 1
Affirm 50
Validate 1
View profile

Avatar
Springboard
Level 7
KiranVedantam1992
Level 7

Likes

195 likes

Total Posts

213 posts

Correct reply

60 solutions
Top badges earned
Springboard
Give Back 5
Ignite 1
Affirm 50
Validate 1
View profile
KiranVedantam1992
Level 7

22-02-2021

Hi @siddupatil,

 

The error clearly says there is some issue in JQuery dependency as you have mentioned. Can you check if the client-libs are loading properly in the publisher? To check it, view the page source and search for the below text which can confirm if the client-libs are loading fine.

<script type="text/javascript" src="...jQuery></script>

 

Hope this helps.

 

Thanks,

Kiran Vedantam.

Answers (0)