sling:orderBefore not working on overlay node /libs/cq/core/content/nav/tools/operations

Avatar

Avatar

bsr060893

Avatar

bsr060893

bsr060893

20-08-2020

Hi,

I wanted to add a new node under opertaions, so i overlaied from /libs to /apps.

If i add sling:orderBefore node and set it to sites, the node is breaking after the code built and the operations are not displayed in the sites.

Is there any issue with the code using sling:orderBefore?

<?xml version="1.0" encoding="UTF-8"?>
<jcr:root xmlns:jcr="http://www.jcp.org/jcr/1.0" xmlns:nt="http://www.jcp.org/jcr/nt/1.0"
jcr:primaryType="nt:unstructured">
<tools jcr:primaryType="nt:unstructured">
<operations jcr:primaryType="nt:unstructured"
sling:orderBefore="sites">
</operations>
</tools>
</jcr:root>

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Arun_Patidar

MVP

Total Posts

3.0K

Likes

1.1K

Correct Reply

861

Avatar

Arun_Patidar

MVP

Total Posts

3.0K

Likes

1.1K

Correct Reply

861
Arun_Patidar
MVP

22-08-2020

Can you check if the property is getting added or not if you deploy using package manager or code?

From your XML, I can see sling namespaces are missing.

 

<jcr:root xmlns:sling="http://sling.apache.org/jcr/sling/1.0" xmlns:granite="http://www.adobe.com/jcr/granite/1.0" xmlns:cq="http://www.day.com/jcr/cq/1.0" xmlns:jcr="http://www.jcp.org/jcr/1.0" xmlns:nt="http://www.jcp.org/jcr/nt/1.0"

Answers (1)

Answers (1)

Avatar

Avatar

Nupur_Jain

MVP

Avatar

Nupur_Jain

MVP

Nupur_Jain
MVP

20-08-2020

Hi @bsr060893 

 

which version of AEM are you using?

I tried and it worked for me.

 

Screenshot from 2020-08-20 22-31-37.pngScreenshot from 2020-08-20 22-31-23.png

 

Thanks!

Nupur