Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

Sightly component labels are not rendering on page.(intermittent issue)

rajum25345098
Level 1
Level 1

Hi Guys,

I am facing issue with sightly component labels. The labels are loading properly sometime, but after couple of hours they are rendered incorrectly(instead of labels only sling:key only)

my component structure is (check the screen shot)

when open a page labels are loading properly(sling:message    value of appropriate sling:key).

but after some time only sling:key    are loading.

I verified in dict.en.json in browser, in first case it is having all the keys,messages but not in the second case.

This is with AEM 6.1

Can you tell me what is the issue here?

4 Replies
Feike_Visser1
Employee
Employee

I assume you use @ i18n to render the labels?

Does the issue happen on both author and publish?

rajum25345098
Level 1
Level 1

Hi Feike,

Sine this is intermittent issue, i can do demo/add a recording.(i will add if i get)

But i will add screen shot of the issue , so that you will get clear picture of the issue.

 

Thanks,

raju.

Feike_Visser1
Employee
Employee

Anyway you can create a sample that demonstrate this issue?

rajum25345098
Level 1
Level 1

Hi, can you check the below image so that you can understand actual issue.

Update- this issue is only in Stage server.

 

Any Idea, how to resolve this?