SDI issue in AEM 6.2

Avatar

Avatar

Manjunath_DJ

Avatar

Manjunath_DJ

Manjunath_DJ

28-12-2016

Hi,

I am trying to implement SDI in AEM + Dispatcher using Sling Dynamic Include 2.2.1

I have followed steps as per https://github.com/Cognifide/Sling-Dynamic-Include 

AEM components embedded in template level as below:

<div data-sly-resource="${'test' @ resourceType='test/components/test'}"></div>  

AEM configuration:

# Configuration created by Apache Sling JCR Installer
include-filter.config.ignoreUrlParams=[""]
include-filter.config.resource-types=["test/components/test"] 
include-filter.config.enabled=B"true"  
include-filter.config.path="/content"
include-filter.config.required_header="Server-Agent\=Communique-Dispatcher"
include-filter.config.include-type="SSI"
include-filter.config.selector="nocache"
include-filter.config.add_comment=B"true" 
include-filter.config.rewrite=B"false"
include-filter.config.ttl=""

Dispatcher configurations :

Made separate httpd config file as below and included in httpd 

LoadModule dispatcher_module modules/disp_apache2.2.dll
 
<IfModule disp_apache2.c>
  DispatcherConfig conf/dispatcher.any
  DispatcherLog    logs/dispatcher.log
  DispatcherLogLevel 3
  DispatcherNoServerHeader 0
  DispatcherDeclineRoot 0
  DispatcherUseProcessedURL 0
  DispatcherPassError 0
</IfModule>
SetOutputFilter INCLUDES

<Directory />
  <IfModule disp_apache2.c>
    SetHandler dispatcher-handler
    ModMimeUsePathInfo On
  </IfModule>
 
  Options FollowSymLinks
  AllowOverride None
</Directory> 

Dispatcher.any with

 /disable-nocache
        {
        /glob "*.nocache.html*"
        /type "deny"
        }

But when am trying to access the page with dispatcher component is not rendered on page but view source include as below:

<div><!-- SDI include (path: /content/test5/_jcr_content/test.nocache.html/test/components/test, resourceType: test/components/test) -->

<!--#include virtual="/content/test5/_jcr_content/test.nocache.html/test/components/test" --></div>    

Thanks,

Manjunath

View Entire Topic

Avatar

Avatar

raja_vijay_sing

Avatar

raja_vijay_sing

raja_vijay_sing

28-12-2016

Hi,

The SDI is configured fine that is why you are able to see the SSI tags. your webserver is not configured to process the server side includes.

Refer

https://httpd.apache.org/docs/current/howto/ssi.html