Script Error in a component after upgrading from 6.2 to 6.4

Avatar

Avatar

dineshr60935615

Avatar

dineshr60935615

dineshr60935615

11-04-2019

Hi,

After upgrading to 6.4 from 6.2 we are getting a error in one of the component and the page is not loading. Below is the error log. Has anyone come across this kind of issue. Help is much appreciated.

1730941_pastedImage_1.png

1730940_pastedImage_0.png.

Replies

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

11-04-2019

Did you rebuild this component in AEM 6.4 environment using the AEM 6.4 UBER JAR and other AEM 6.4 dependencies? That is what you should do.

Avatar

Avatar

dineshr60935615

Avatar

dineshr60935615

dineshr60935615

11-04-2019

Hi,

Can we know the exact dependencies for AEM 6.4 to ensure we have all in our POM.

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

14-04-2019

We have many HELPX articles that show this. For example:

Adobe Experience Manager Help | Querying Adobe Experience Manager 6.4 JCR data using the QueryBuilde...

Or simply see this article that talks about an AEM 6.4 project using UBER 6.4:

Creating an Adobe Experience Manager 6.4 Project using Adobe Maven Archetype 13

Hope this helps.