Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

RTE not showing all the fields

harsingh91
Level 3
Level 3

Hello Team,

When I add text component on my page, it shows me all the fields, but after editing it once only some field is available for editing. Please see the steps below for reproducing it.

  1. Drag and drop Text component
  2. Click on 'Edit' icon
  3. Click on maximize icon, you should see the below view. It looks fine
  4. Now enter some text, and return to minimize view, like below
  5. Now instead of clicking on 'Ok', click on 'Cancel'. It should return to the initial view like below
  6. Now do the above process again (click on edit, then maximize it and check the view)

Thanks,
Harshit

6 Replies
smacdonald2008
Level 10
Level 10

Your graphics are not showing - can you please fix to make your issue clear.

smacdonald2008
Level 10
Level 10

Also - from your description - seems like you are dropping on a new text component and never set text in it and click Done.

Step 5 - you enter text - which is valid. Then for this text to take hold - you need to click the Check button (done).

harsingh91
Level 3
Level 3

Hello,

Sorry for wrong links. Please find the attachments below.

1. Drag and drop text (RTE) component.

2. Click on Edit buttonStep1.PNG

3. Click on Full Screen and write some text.Step2.PNG

4. Click on minimize

5. Now click on "Close",as highlighted Step3.PNG

6 Now, click on "Edit" againStep4.PNG

7. Now click on Full Screen again as highlighted Step5.PNG

8. Now, in the edit screen, you can see there are some options missing in comparision to first time RTE.Step6.PNG

Hope it helps.

Thanks in advance,

smacdonald2008
Level 10
Level 10

These options are the default for the RTE.

If you want to add more options - you need to set more plug-in nodes in the component's dialog.

To learn how to do this - see this document: Configuring Experience Manager Rich Text Editor Plugins in a Touch UI Component Dialog

harsingh91
Level 3
Level 3

Hello,

I got it what are you saying. But my issue is that, options which are available in first time editing (See step 3 pic) are not available in second time (See step 8 pic).

Hope I am more clear this time.

Thanks,

Harshit

chirran414
Level 5
Level 5

harsingh91​ your attachments are not showing.

Based on your question is it something related to missing RTE plugins mentioned in the below link?

RTE Plugins are missing in Core Text (V1, V2) component.