Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Resolved Segments in contexthub toolbar showing blank

Avatar

Avatar
Validate 1
Level 2
vinaydkarde
Level 2

Likes

3 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
vinaydkarde
Level 2

Likes

3 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
vinaydkarde
Level 2

10-10-2018

I am trying to achieve personalisation in AEM 6.3. I am not able to see "Resolved Segments" in contexthub toolbar in my project. Whereas if I try in we-retail site, I can see "resolved segments" such as female,age-over-30, season-summer etc.

Can somebody help me why is it happening only in my project whereas it works fine in we-retail site? PFB attached snapshots.

Blank_resolved_segments.PNGWe-retail_resolved_segments.PNG

View Entire Topic

Avatar

Avatar
Validate 1
Level 2
vinaydkarde
Level 2

Likes

3 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
vinaydkarde
Level 2

Likes

3 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
vinaydkarde
Level 2

18-10-2018

Hi Scott (smacdonald2008),

The above article was very useful. I could debug the issue based on above example. Once I added below dependency, "Resolved segments" section was showing up correctly.

<sly data-sly-use.clientLib="/libs/granite/sightly/templates/clientlib.html"

     data-sly-call="${clientlib.all @ categories='we-retail.dependencies'}"/>