Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Replication Preprocessor not working in Publisher

Avatar

Avatar
Springboard
MVP
Shashi_Mulugu
MVP

Likes

224 likes

Total Posts

283 posts

Correct Reply

65 solutions
Top badges earned
Springboard
Bedrock
Validate 1
Applaud 100
Establish
View profile

Avatar
Springboard
MVP
Shashi_Mulugu
MVP

Likes

224 likes

Total Posts

283 posts

Correct Reply

65 solutions
Top badges earned
Springboard
Bedrock
Validate 1
Applaud 100
Establish
View profile
Shashi_Mulugu
MVP

19-03-2020

Hello @kautuk_sahni ,

 

We are trying to create a Replication Preprocessor in AEM Publisher which should execute for Activate and Deactivate and Fire an API call if the page is deactivated with Page Path and Page Template, as this api has to be called only for few templates. We are able to execute it successfully but we are unable to get hold of resource as it is already deactivated while this preprocessor is executed. We need resource details as we need to check with if the item is Page or Asset and get template name if that is Page.

 

Any thoughts will be appreciated or please help me in connecting with appropriate members if in case.

 

Thanks 

 

Shashi

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,357 likes

Total Posts

3,228 posts

Correct Reply

918 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,357 likes

Total Posts

3,228 posts

Correct Reply

918 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

19-03-2020

Answers (0)