Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Renditions are not getting created on image upload

Avatar

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
manish_anand
Level 3

05-06-2018

Hi,

Renditions are not getting created on image upload. But when i restart sling event bundle it works fine.

This has happened multiple times. I tried to analyze the Root Cause ad found below error in log

28.05.2018 09:31:57.563 *INFO* [sling-oak-observation-8023] org.apache.sling.event.impl.jobs.queues.JobQueueImpl.Granite Workflow Queue Starting job queue Granite Workflow Queue

28.05.2018 09:31:57.579 *INFO* [sling-oak-observation-8023] org.apache.sling.event Service [QueueMBean for queue Granite Workflow Queue,8244, [org.apache.sling.event.jobs.jmx.StatisticsMBean]] ServiceEvent REGISTERED

28.05.2018 09:31:57.657 *ERROR* [JobHandler: /etc/workflow/instances/server0/2018-05-26/update_asset_5:/content/dam/myProject/en/2018/week-22/news-quiz/w22_May_news_quiz_thumbnail.jpg/jcr:content/renditions/original] com.day.cq.dam.core.process.MetadataProcessorProcess execute: cannot extract metadata, no handler found for asset [/content/dam/myProject/en/2018/week-22/news-quiz/w22_May_news_quiz_thumbnail.jpg] with mime type [image/jpeg]

28.05.2018 09:31:57.657 *INFO* [JobHandler: /etc/workflow/instances/server0/2018-05-26/update_asset_5:/content/dam/myProject/en/2018/week-22/news-quiz/w22_May_news_quiz_thumbnail.jpg/jcr:content/renditions/original] com.day.cq.dam.video.FFMpegThumbnailProcess execute: asset [/content/dam/myProject/en/2018/week-22/news-quiz/w22_May_news_quiz_thumbnail.jpg] is not of a video mime type, asset ignored.

28.05.2018 09:31:57.657 *INFO* [JobHandler: /etc/workflow/instances/server0/2018-05-26/update_asset_5:/content/dam/myProject/en/2018/week-22/news-quiz/w22_May_news_quiz_thumbnail.jpg/jcr:content/renditions/original] com.day.cq.dam.core.process.CommandLineProcess execute: mime type [image/jpeg] of asset [/content/dam/myProject/en/2018/week-22/news-quiz/w22_May_news_quiz_thumbnail.jpg] is not in list of accepted mime types [[image/eps, image/x-eps, application/postscript, application/eps, application/x-eps]], ignoring.

28.05.2018 09:31:57.657 *INFO* [JobHandler: /etc/workflow/instances/server0/2018-05-26/update_asset_5:/content/dam/myProject/en/2018/week-22/news-quiz/w22_May_news_quiz_thumbnail.jpg/jcr:content/renditions/original] com.day.cq.dam.video.FFMpegTranscodeProcess execute: asset [/content/dam/myProject/en/2018/week-22/news-quiz/w22_May_news_quiz_thumbnail.jpg] is not of a video mime type, asset ignored.

28.05.2018 09:31:57.672 *ERROR* [JobHandler: /etc/workflow/instances/server0/2018-05-26/update_asset_5:/content/dam/myProject/en/2018/week-22/news-quiz/w22_May_news_quiz_thumbnail.jpg/jcr:content/renditions/original] com.day.cq.dam.core.impl.gfx.CommonsGfxRenderer Could not render: wid=375&hei=281&fit=constrain,1&fmt=png-alpha&rszfast=1&layer=comp&layer=0&src=/content/dam/myProject/en/2018/week-22/news-quiz/w22_May_news_quiz_thumbnail.jpg/jcr:content/renditions/original

java.lang.NullPointerException: null

at com.day.cq.dam.core.impl.gfx.CommonsGfxRenderer.createImageLayer(CommonsGfxRenderer.java:487)

at com.day.cq.dam.core.impl.gfx.CommonsGfxRenderer.createLayer(CommonsGfxRenderer.java:166)

at com.day.cq.dam.core.impl.gfx.CommonsGfxRenderer.render(CommonsGfxRenderer.java:117)

at com.adobe.cq.gfx.impl.GfxImpl.render(GfxImpl.java:94)

at com.day.cq.dam.core.impl.RenditionMakerImpl$PlanBasedTemplate.apply(RenditionMakerImpl.java:131)

at com.day.cq.dam.core.impl.RenditionMakerImpl.generateRenditions(RenditionMakerImpl.java:210)

at com.day.cq.dam.core.process.CreateThumbnailProcess.createThumbnails(CreateThumbnailProcess.java:120)

at com.day.cq.dam.core.process.ThumbnailProcess.execute(ThumbnailProcess.java:94)

at com.day.cq.workflow.compatibility.CQWorkflowProcessRunner.execute(CQWorkflowProcessRunner.java:93)

at com.adobe.granite.workflow.core.job.HandlerBase.executeProcess(HandlerBase.java:189)

at com.adobe.granite.workflow.core.job.JobHandler.process(JobHandler.java:258)

at org.apache.sling.event.impl.jobs.JobConsumerManager$JobConsumerWrapper.process(JobConsumerManager.java:500)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.startJob(JobQueueImpl.java:291)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl.access$100(JobQueueImpl.java:58)

at org.apache.sling.event.impl.jobs.queues.JobQueueImpl$1.run(JobQueueImpl.java:227)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

at java.lang.Thread.run(Thread.java:745)

this error is repeating multiple times.  Did anyone face this similar issue.?

I havent modified dam update asset workflow.

regards,

Manish

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

06-06-2018

If you need to restart the bundle for this to work - its a bug. It should work with the Bundle in active state. Team said to file a bug - this is something that the community cannot help with - you need to talk to support for a possible patch.

Answers (7)

Answers (7)

Avatar

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
manish_anand
Level 3

06-06-2018

Any help?

Avatar

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
manish_anand
Level 3

05-06-2018

Hi bsloki,

i am not getting this error all the time. At times when an author upload an asset we get this error.

when i restart sling event bundle it works fine instantly.

i got this error 2-3 times now and than i started looking into this.

mostly my author use jpg files.

Avatar

Avatar
Validate 25
MVP
bsloki
MVP

Likes

182 likes

Total Posts

1,859 posts

Correct Reply

545 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Boost 50
Boost 5
View profile

Avatar
Validate 25
MVP
bsloki
MVP

Likes

182 likes

Total Posts

1,859 posts

Correct Reply

545 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Boost 50
Boost 5
View profile
bsloki
MVP

05-06-2018

Is this happening for all the assets or only specific types of assets?

Can you try this on new 6.3 instance with sp1 and check if you are facing the same issue ?

Avatar

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
manish_anand
Level 3

05-06-2018

Thanks.

waiting for your reply.

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

05-06-2018

This appears to be an upgrade issue. I will see if this is a known issue.

Avatar

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
manish_anand
Level 3

Likes

19 likes

Total Posts

56 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
manish_anand
Level 3

05-06-2018

Recently migrated from 6.1 to 6.3 sp1

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

05-06-2018

What AEM version are you using?