"Root node is not accessible" error when Test Connection is triggered in default replication agent on Author

Avatar

Avatar

ak481808

Avatar

ak481808

ak481808

16-02-2018

Hello Everyone,

We upgraded from AEM 6.0 to AEM 6.3 (Not sure if this is an issue related to AEM 6.3)

The default replication agent is not working as expected. When Test Connection is done, it throws below error in the logs:

16.02.2018 17:55:24.549 *ERROR* [10.150.44.28 [1518783924487] GET /etc/replication/agents.author/publish.test.html HTTP/1.1] com.day.cq.cq-audit [com.day.cq.audit.impl.DefaultAuditLog(1301)] The activate method has thrown an exception (javax.jcr.AccessDeniedException: Root node is not accessible.)

javax.jcr.AccessDeniedException: Root node is not accessible.

        at org.apache.jackrabbit.oak.jcr.session.SessionImpl$4.perform(SessionImpl.java:294)

        at org.apache.jackrabbit.oak.jcr.session.SessionImpl$4.perform(SessionImpl.java:288)

        at org.apache.jackrabbit.oak.jcr.delegate.SessionDelegate.perform(SessionDelegate.java:208)

        at org.apache.jackrabbit.oak.jcr.session.SessionImpl.getRootNode(SessionImpl.java:288)

        at com.adobe.granite.repository.impl.CRX3SessionImpl.getRootNode(CRX3SessionImpl.java:138)

After this, it keeps on throwing below error -

16.02.2018 13:14:15.653 *ERROR* [FelixDispatchQueue] com.day.cq.wcm.cq-msm-core FrameworkEvent ERROR (org.osgi.framework.ServiceException: Service factory returned null. (Component: com.day.cq.wcm.msm.impl.RolloutExceptionHandlerImpl (1734)))

org.osgi.framework.ServiceException: Service factory returned null. (Component: com.day.cq.wcm.msm.impl.RolloutExceptionHandlerImpl (1734))

        at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:380)

I have tried troubleshooting steps -

1. Did a ping from author to publish VM, Ping is fine.

2. Did telnet from author to publish VM, that is also fine.

3. Checked all access in publish server for the admin user, all access is as expected)

4. The replication queue is clear.

5. However, when I do a wget from author to this URL I get this -

wget http://<publishURL>:4503/bin/receive

--2018-02-16 18:16:17--  http://<publishURL>:4503/bin/receive

Connecting to <publishURL>:4503... connected.

HTTP request sent, awaiting response... 401 Unauthorized

Authorization failed.

Could this be the problem? Please let me know if someone has faced the same sort of issue.

View Entire Topic

Avatar

Avatar

jaskiratb1369

Avatar

jaskiratb1369

jaskiratb1369

19-12-2018

some where in code login user is trying to access root node

for eg: Node root = session.getRootNode();

To check login in  as http://localhost:4502/useradmin 

relative path as : /useradmin

below is the example of without root node access permission : see the first line in the folder path no root access

withoutrootnode.JPG

for this logged in user provide at least read access permission as below :

withrootnode.JPG