Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.

Process failed AEM as Cloud Service Report

Avatar

Level 5

Hey All,

 

So every once and a while uploading an image we  get "Process failed". I know how to reprocess and that will fix it, but is there a way I can do a report against the DAM to find all assets that have "Process failed"? 

 

Thanks

12 Replies

Avatar

Level 4

digarg31_0-1655818230853.png

You could look for this metadata property dam:assetState. Either add this in the search filter for search on this or you can also create a custom report using ACS Commons reports that can also be downloaded as csv report

https://adobe-consulting-services.github.io/acs-aem-commons/features/report-builder/index.html

 

Screenshot 2022-06-21 at 7.00.15 PM.png

Avatar

Level 5

problem with those reports I get a AEM cloud service error

 

2022-06-21 09_37_51-AEM Cloud Service.png

Avatar

Level 4

Did you add any search parameters ? If yes , there is an issue with field type on the cloud that I noticed. So I fixed that field type locally via crxde or copy-pasted search params from other reports. I ran the above report on the cloud instance itself and it gave me the results. This error comes if anything is wrong with configuration.

Avatar

Level 5

I get the same issue when I try to edit any of the report for example 

 

 

/editor.html/var/acs-commons/reports/sample-page-report.html

 

that gives me it too, so I can't even build it. Locally I can build it just fine

 

Avatar

Level 4

Are you able to run and view results of sample report ? If yes , can you just update the query (change path ) and results section as mentioned in snapshot.

Avatar

Level 5

nope can't run or view any reports, even the ones out of box. I get a 404 for http://www.adobe.com/consulting/acs-aem-commons/wcmmode does that have anything to do with it?

Avatar

Level 4

what is the acs aem commons version you are using? Trying installing latest one.I have 5.0.14 on cloud.

Avatar

Level 4

will have to check then. Meanwhile you may want to try adding it in search filter.

Avatar

Level 5

yeah I am using that, but would still like to use acs commons as it is nicer for the user lol.