Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Post Migration of Tags not showing in PageProperties

Avatar

Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
Level 2

29-05-2021

Hello Friends,

 

I am performing AEM 6.4 to 6.5 migration, the tags have been copied to new location /content/cq:tags and old location /etc/tags have been deleted and content pages are re-installed. Post migration i can see the tag property ["currentPageTag"] is coming into the page nodes which is absolutely fine and my old tags are retained in nodes.

Issue: the tag values stored in the nodes as property["currentPageTag"] are not coming/displaying in page properties under current Page Tag section, its coming blank so anyone will have an impression that this page doesn't have any tags associated and if we select any tag from tag picker it overwrites the previous value of tag stored in page node as a property.

Any guess how to display the older tag values in page properties?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 100
Level 10
asutosh_jena
Level 10

Likes

559 likes

Total Posts

676 posts

Correct Reply

194 solutions
Top badges earned
Give Back 100
Boost 500
Affirm 100
Ignite 1
Establish
View profile

Avatar
Give Back 100
Level 10
asutosh_jena
Level 10

Likes

559 likes

Total Posts

676 posts

Correct Reply

194 solutions
Top badges earned
Give Back 100
Boost 500
Affirm 100
Ignite 1
Establish
View profile
asutosh_jena
Level 10

29-05-2021

Hi @shivama92274331 

 

Please restart Day Communique 5 Tagging OSGi bundle at /system/console/bundles/com.day.cq.cq-tagging for AEM to recognize the New Location contains content and should be used.

Restarting the Day Communique Tagging OSGi bundle will only register the New Location as the tag root if the Previous Location is empty.

References to the Previous Location will continue to work after migrating to New Location for all functionality that leverages AEM's TagManager API for tag resolution.

 

PS: My personal opinion will be to restart the complete instance than restarting only the above bundle 🙂

 

Thanks!

Answers (2)

Answers (2)

Avatar

Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Give Back
Level 2
shivama92274331
Level 2

Likes

4 likes

Total Posts

18 posts

Correct Reply

2 solutions
Top badges earned
Give Back
Boost 3
Boost 1
Affirm 1
View profile
shivama92274331
Level 2

31-05-2021

Hello Friends,

 

The issue is resolved now!

 

Problem was after successful migration of tags the corresponding value of tag saved in page nodes was not displaying on page properties because the corresponding tag and its path was not available in cq:tags, once we rectified with the tags package its started showing up tag value on page properties.

 

Thanks for all of your suggestions.

 

Regards,

Shivam

Avatar

Avatar
Springboard
MVP
Shashi_Mulugu
MVP

Likes

224 likes

Total Posts

283 posts

Correct Reply

65 solutions
Top badges earned
Springboard
Bedrock
Validate 1
Applaud 100
Establish
View profile

Avatar
Springboard
MVP
Shashi_Mulugu
MVP

Likes

224 likes

Total Posts

283 posts

Correct Reply

65 solutions
Top badges earned
Springboard
Bedrock
Validate 1
Applaud 100
Establish
View profile
Shashi_Mulugu
MVP

31-05-2021

@shivama92274331 Please reauthor once for one page and cross check what is the difference between old and new tagging..