Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

POST Call to AEM from SFDC gives HTTP Error 403

Avatar

Avatar
Validate 10
Level 3
srikanthp689160
Level 3

Likes

20 likes

Total Posts

95 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 3
srikanthp689160
Level 3

Likes

20 likes

Total Posts

95 posts

Correct Reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
srikanthp689160
Level 3

14-09-2020

Hi All,

We are loading AEM Forms in an iframe on an AEM web page and form action url is that SFDC Pardot system.

After successful form submission SFDC Pardot system does a POST call to success page(AEM page) which we trying to load in the same iframe but see below error.

HTTP ERROR 403
Problem accessing /global/en/form-success.html. Reason:
Forbidden

 

We have tried allowing POST in dispatcher filter for below url but still see same issue.

/0182 { /type "allow" /method "POST" /path "/global/en/form-success" /extension "html"}

 

Dispatcher Access log:

10.43.0.50 "stage-www.xxx.com" brunswick [14/Sep/2020:09:31:30 +0000] "POST /global/en/form-success.html HTTP/1.1" 403 209 "https://go.pardot.com/l/70842/2020-07-14/xxx" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36"

Dispatcher log has below information

[Mon Sep 14 07:20:02 2020] [D] [pid 23527 (tid 140434929665792)] Found farm publishfarm for stage-www.xxx.com
[Mon Sep 14 07:20:02 2020] [D] [pid 23527 (tid 140434929665792)] checking [/global/en/form-success.html]
[Mon Sep 14 07:20:02 2020] [D] [pid 23527 (tid 140434929665792)] request method is neither GET nor HEAD: POST
[Mon Sep 14 07:20:02 2020] [D] [pid 23527 (tid 140434929665792)] cache-action for [/global/en/form-success.html]: NONE
[Mon Sep 14 07:20:02 2020] [D] [pid 23527 (tid 140434929665792)] Creating new socket: 10.43.0.6:4503
[Mon Sep 14 07:20:02 2020] [D] [pid 23527 (tid 140434929665792)] Connected to backend 0 (10.43.0.6:4503)

 

Any inputs what can be done to fix this issue?

 

Thanks

Srikanth

403 Dispatcher

Accepted Solutions (0)

Answers (1)

Answers (1)

Avatar

Avatar
Validate 1
MVP
Albin_Issac
MVP

Likes

106 likes

Total Posts

119 posts

Correct Reply

33 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile

Avatar
Validate 1
MVP
Albin_Issac
MVP

Likes

106 likes

Total Posts

119 posts

Correct Reply

33 solutions
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile
Albin_Issac
MVP

14-09-2020

Hi

The log shows the dispatcher is not blocking the request and connected to the backend

Are you sending the basic authentication headers from Salesforce?

Does the user have the access to perform the required operations in AEM?

Regards

Albin I

www.albinsblog.com