Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Packaging workflows for maven build not working as expected

Avatar

Avatar
Boost 5
Level 2
RobertInfosys
Level 2

Likes

5 likes

Total Posts

11 posts

Correct Reply

0 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Give Back 5
Give Back 3
View profile

Avatar
Boost 5
Level 2
RobertInfosys
Level 2

Likes

5 likes

Total Posts

11 posts

Correct Reply

0 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Give Back 5
Give Back 3
View profile
RobertInfosys
Level 2

09-06-2021

I'm trying to include a custom workflow and launcher in my maven package. I've created an archetype using the aem-project-archetype 27 settings for AEM 6.5. I have created a custom workflow that has one step which is a process step. I have also added a launcher for this workflow as well. I then created a package with the settings for the workflow and launcher held in the /var/workflows/models/custom-workflow, /conf/global/settings/workflow/launcher/config/[workflow-id] and /conf/global/setting/workflow/models/custom-workflow. I then downloaded the package and expanded it and added the files to my project.

I added the paths to the filter.xml and set the mode to merge. Then when I build, all of the OOTB workflows are deleted and only my custom workflow is left.

Including the path all the way to the custom workflow name only generates build errors due to rules violations. 

Does someone know of an example of including a workflow in a build package that I could review to correct mine?

filters maven package workflows

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Ignite 3
Level 5
davidjgonzalezzzz
Level 5

Likes

68 likes

Total Posts

77 posts

Correct Reply

31 solutions
Top badges earned
Ignite 3
Affirm 25
Ignite 1
Give Back 5
Give Back 3
View profile

Avatar
Ignite 3
Level 5
davidjgonzalezzzz
Level 5

Likes

68 likes

Total Posts

77 posts

Correct Reply

31 solutions
Top badges earned
Ignite 3
Affirm 25
Ignite 1
Give Back 5
Give Back 3
View profile
davidjgonzalezzzz
Level 5

09-06-2021

Can you post your package's filter.xml definition?

 

It sounds like your filter.xml is too broad, and thus wiping out everything in the JCR at these paths, and only adding what is in your project.

Answers (0)