Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Package Manager - Uploading fails on ACS AEM Commons 5.0.14

Avatar

Community Advisor

Hi there, upload fails on the ACS AEM Commons 5.0.14 zip file with this error, what could be the reason for this?

 

Version Adobe Experience Manager 2021.11.6058.20211123T163652Z-211000

 

acs_commons_upload_fail.png

 

 

 

 

6 Replies

Avatar

Community Advisor

@Sebastiane_Edberg_ What's the AEM version you are using ?  Can you check your error log for more information ?

 

Please refer this article: https://githubmemory.com/repo/Adobe-Consulting-Services/acs-aem-commons/issues/2566

 

Avatar

Community Advisor

i am not seeing anything related to this error in the logs actually

Avatar

Community Advisor

Hi @Sebastiane_Edberg_ ,

 

I am unable to replicate this issue in local instance of aem-sdk-2021.11.6058.20211123T163652Z-211000. I am able to upload and install ACS commons 5.0.14 package successfully.

 

kishorekumar14_0-1638885078520.png

 

Avatar

Community Advisor

ok good, any idea what the error means (content not supported at runtime) ?

Avatar

Community Advisor

Actually no, tried another package (smart-tags-to-metadata-wf-model-3.0.0.zip) and it installed fine

Avatar

Community Advisor

@Raja-kp inthis overview here https://adobe-consulting-services.github.io/acs-aem-commons/pages/compatibility.html#aem-as-a-cloud-... theres a lot of dependencies missing in the aem commons package for AEM AaCS so I would assume this is the cause of the error when uploading, not sure if @Kishore_Kumar_ was using AEM AaCS for the test though so i might be wrong

Avatar

Community Advisor

@Kishore_Kumar_ any idea what i should start troubleshooting? is it a dependency that is not installed or could it be permission related? 

Avatar

Community Advisor

Hi @Sebastiane_Edberg_ ,

 

May I know how you are trying to install?

 

Directly via package manager? If yes, It won't work in AemaaCS since it is containing immutable paths and it won't allow you to install and we have to add ACS Commons depedency on our project to make use of it.

Avatar

Level 4

@Kishore_Kumar_ 
How to add ACS Commons depedency on our project, please? Do you mean adding ACS AEM Commons locally and then deploying to git?

Avatar

Community Advisor

@Kishore_Kumar_ 

 

i get these build errors when adding dependencies

980 [main] [ERROR] ValidationViolation: "jackrabbit-filter: Node '/apps/my-app-packages/application/install/acs-aem-commons-ui.apps-5.1.0-min.zip' is not contained in any of the filter rules", filePath=jcr_root/apps/my-app-packages/application/install/acs-aem-commons-ui.apps-5.1.0-min.zip
18:44:33,983 [main] [ERROR] ValidationViolation: "jackrabbit-filter: Node '/apps/my-app-packages/content/install/acs-aem-commons-ui.content-5.1.0-min.zip' is not contained in any of the filter rules", filePath=jcr_root/apps/my-app-packages/content/install/acs-aem-commons-ui.content-5.1.0-min.zip

 

what does that error mean? 

 

 

Avatar

Level 4

@Sebastiane_Edberg_ 
The package name - "my-app-packages" should be invalid. I got the same error. 😂
We can change it to an existing/valid package name instead. If package name is a new one like "acs-commons-packages", we may need to add it into filter ("all\src\main\content\META-INF\vault\filter.xml") as well.
Anyway, by the above changes, I passed the validation step. However, I got deploy error at the last step - "Deploy to Dev". Not sure why. 😅

Avatar

Community Advisor

Hi @Sebastiane_Edberg_ ,

 

/apps/my-app-packages/application/install/acs-aem-commons-ui.apps-5.1.0-min.zip

 

Instead of my-app-packages you need to specify your project specific package name in embedded target value of filevault-package-maven-plugin in 'all' pom.xml

 

  

Avatar

Level 4

@Kishore_Kumar_ 
During the deployment to dev, I tried many changes and always got failed in the last step - "Deploy to Dev" for AEM as a cloud service. And the following messages are printed in logs.

Failed logs

2021-12-31T12:11:00+0000 Summary of events during the deployment step:
2021-12-31T12:11:00+0000 Begin deployment in poc-jira-asset-dev [CorrelationId: 8666415]
2021-12-31T12:11:03+0000 Update author indexes job has started.
2021-12-31T12:13:32+0000 Update author indexes job has finished successfully.
2021-12-31T12:13:32+0000 Update publish indexes job has started.
2021-12-31T12:13:43+0000 Update publish indexes job has finished successfully.
2021-12-31T12:15:41+0000 Build Transform job has started.
2021-12-31T12:15:41+0000 Build Transform job has finished successfully.
2021-12-31T13:16:00+0000 Failed deployment in poc-jira-asset-dev
2021-12-31T13:16:00+0000 Detailed events during the deployment step:
...
[2021/12/31 12:12:13] [ info] [engine] started (pid=19)
[2021/12/31 12:12:13] [ info] [storage] version=1.1.1, initializing...
[2021/12/31 12:12:13] [ info] [storage] in-memory
[2021/12/31 12:12:13] [ info] [storage] normal synchronization mode, checksum disabled, max_chunks_up=128
[2021/12/31 12:12:13] [error] [sqldb] cannot open database /var/log/aem/logs_error.db
[2021/12/31 12:12:13] [error] [input:tail:tail.1] could not open/create database

Normal logs

2021-12-30T11:52:54+0000 Summary of events during the deployment step:
2021-12-30T11:52:54+0000 Begin deployment in poc-jira-asset-dev [CorrelationId: 8662021]
2021-12-30T11:52:57+0000 Update author indexes job has started.
2021-12-30T11:57:49+0000 Update author indexes job has finished successfully.
2021-12-30T11:57:49+0000 Update publish indexes job has started.
2021-12-30T11:58:00+0000 Update publish indexes job has finished successfully.
2021-12-30T11:59:58+0000 Build Transform job has started.
2021-12-30T11:59:58+0000 Build Transform job has finished successfully.
2021-12-30T12:03:17+0000 Install mutable content job has started.
2021-12-30T12:05:49+0000 Install mutable content job has finished successfully.
2021-12-30T12:05:50+0000 Finished deployment in poc-jira-asset-dev
2021-12-30T12:05:50+0000 Detailed events during the deployment step:
...
[2021/12/30 12:03:41] [ info] [engine] started (pid=19)
[2021/12/30 12:03:41] [ info] [storage] version=1.1.1, initializing...
[2021/12/30 12:03:41] [ info] [storage] in-memory
[2021/12/30 12:03:41] [ info] [storage] normal synchronization mode, checksum disabled, max_chunks_up=128
[2021/12/30 12:03:41] [ info] [http_server] listen iface=0.0.0.0 tcp_port=2020
[2021/12/30 12:03:41] [ info] [sp] stream processor started

As you see, the words in bold are differences. Within failed logs, there are no installing mutable content job steps, but there are error - "cannot open database /var/log/aem/logs_error.db"
Do you have any ideas? Thanks.


Avatar

Community Advisor

@Hugh_Shao @Kishore_Kumar_ 

 

I now get the errors described here when deploying to dev https://github.com/Adobe-Consulting-Services/acs-aem-commons/issues/2604

Code scanning partially passes with a "D" in reliability rating, there are two lines marked as critical:

adobe/consulting:acs-aem-commons-ui.apps:5.1.0,0,The product interface com.day.cq.search.Query annotated with @ProviderType should not be implemented by custom code. Detected in com.adobe.acs.commons.search.CloseableQuery contained in /apps/acs-commons/install/acs-aem-commons-bundle-5.1.0.jar.,Bug,Critical,30m,CQRules:CQBP-84,cqsoftwarequality,https://www.adobe.com/go/aem_cmcq_cqbp-84_en

adobe/consulting:acs-aem-commons-ui.apps:5.1.0,0,The product interface com.day.cq.search.Query annotated with @ProviderType should not be implemented by custom code. Detected in com.adobe.acs.commons.wrap.cqsearch.QueryIWrap contained in /apps/acs-commons/install/acs-aem-commons-bundle-5.1.0.jar.,Bug,Critical,30m,CQRules:CQBP-84,cqsoftwarequality,https://www.adobe.com/go/aem_cmcq_cqbp-84_en

 

 

It is possible to override and continue build in pipeline but maybe theres a better option?

Avatar

Level 4

Oh, yes, there is an override switch in Review Summary dialog under Code Scanning step. You can try it.

Avatar

Level 3

Has anyone seen or resolved this particular error on Deployment or know what it is referring to?

The cannot open database /var/log/aem/logs_error.db