package manager issue

Avatar

Avatar
Validate 1
Level 2
Anton_Smulskiy
Level 2

Likes

3 likes

Total Posts

35 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile

Avatar
Validate 1
Level 2
Anton_Smulskiy
Level 2

Likes

3 likes

Total Posts

35 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile
Anton_Smulskiy
Level 2

12-07-2017

Hi,

I have a strange issue: cannot install or uninstall any package:

1247860_pastedImage_0.png

Install Package: /etc/packages/my_packages/footer.zip

Wed Jul 12 2017 12:32:45 GMT+0300 (FLE Daylight Time)

Installing content

Error during processing:

java.lang.NoClassDefFoundError: bom/sun/org/apache/xerces/internal/xni/parser/XMLInputSource
...

So, somehow it looks for "bom/sun/org/apache/xerces/internal/xni/parser/XMLInputSource"

But it should be "com/sun/org/apache/xerces/internal/xni/parser/XMLInputSource" I believe.

Does anybody know why it happened and what how to fix it?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 2
Anton_Smulskiy
Level 2

Likes

3 likes

Total Posts

35 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile

Avatar
Validate 1
Level 2
Anton_Smulskiy
Level 2

Likes

3 likes

Total Posts

35 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile
Anton_Smulskiy
Level 2

12-07-2017

AEM restart didn't help. But then I reboot my PC, the issue has gone. Have not idea what that was...

Answers (2)

Answers (2)

Avatar

Avatar
Validate 1
Level 2
Anton_Smulskiy
Level 2

Likes

3 likes

Total Posts

35 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile

Avatar
Validate 1
Level 2
Anton_Smulskiy
Level 2

Likes

3 likes

Total Posts

35 posts

Correct reply

4 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile
Anton_Smulskiy
Level 2

12-07-2017

The package is a valid AEM package

Avatar

Avatar
Boost 50
Level 6
Techaspect_Solu
Level 6

Likes

63 likes

Total Posts

150 posts

Correct reply

79 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile

Avatar
Boost 50
Level 6
Techaspect_Solu
Level 6

Likes

63 likes

Total Posts

150 posts

Correct reply

79 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile
Techaspect_Solu
Level 6

12-07-2017

Hi Anton,

The package which you are trying to install is not proper.

If you extract and validate your package you need to see the folders like

Main Folder(your package)

--jcr_root

--META-INF

Please find a proper package and try installing it again.

Thanks,

Techaspect Solutions Pvt Ltd.

http://www.techaspect.com/