Package download and upload

shaheenas113483

26-03-2019

When I create a package in package manager, I build and install it, after which I download the package, but that gets downloaded a folder instead of a zipped file. Next if I try to upload the same page again after zipping it, it shows me error: as given in the image. Screenshot 2019-03-27 at 11.30.45 AM.png

What might be wrong?

Accepted Solutions (1)

Accepted Solutions (1)

PuzanovsP

MVP

28-03-2019

OOTB Package manager provides only .zip if your Mac/OS decides to unzip it, it's a matter of you to config OS[1] in a way that package won't be unzipped or zip the folder back correctly, without loosing essential info for package manager system.

[1] https://www.addictivetips.com/mac-os/stop-automatically-unzipping-files-in-safari/

Regards,

Peter

Answers (9)

Answers (9)

shaheenas113483

27-03-2019

I have checked, it's not there.

Infact, the problem is really peculiar. At times when I download a package, I get zipped file, which I can upload. But, at other times when I download, I get unzipped file, which on compressing doesn't gets uploaded!

shaheenas113483

27-03-2019

I use Mac.

When I get the downloaded folder I created a zip using the jcr_root and meta_inf folders, only that zip get uploaded successfully. But if I try to zip the folder itself, which contains the jcr_root and meta_inf, that doesn't get uploaded.

shaheenas113483

27-03-2019

I have cropped the area including content foldr in the provided image. I have restarted and created instance several times, but it doesn't help me.

Prince_Shivhare

27-03-2019

It's weird, as you can also see package extension is ZIP.

probably can you try giving some content folder in the filter? because I Can't see anything you have selected from a filter.

Also if that doesn't work try restarting the AEM or check the same thing with your local with the same AEM version and after deleting the quickstart folder. something might be corrupt.

~ Prince

shaheenas113483

26-03-2019

Yes, I created the package from AEM Package Manager, it is showing PackageName.zip but it getting downloaded as a folder.

Screenshot 2019-03-27 at 12.15.54 PM.png

How can I prevent it from getting downloaded as a folder? Is it some settings of the browse?

Hemant_arora

26-03-2019

check the jcr_root folder in the zip file. a package must have the jcr_root folder. also it should not get downloaded as a folder. it should be a zip file.

are you creating package using aem package manager ?