Overlayed emulator not working in 6.5

Avatar

Avatar

mandips70257608

Avatar

mandips70257608

mandips70257608

15-05-2019

Hello all,

We recently upgraded to AEM 6.5 version. The problem we encountered with that is our custom emulator, which we made by overlaying "/etc/mobile/groups/responsive" inside the /etc folder itself is not working in 6.5 version.

I tried multiple things like overlaying the OOTB emulator under /apps/company/components/. But that also does not work.

Does anyone have some idea why that is not working? Please help.

Thanks,

Mandip

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

mandips70257608

Avatar

mandips70257608

mandips70257608

16-05-2019

Thank you for the response!

I was able to figure it out. So, it seems that the path to emulator is changed from /etc/mobile/groups/* to /libs/settings/mobile/groups/* in 6.5. To make it work, I just copied the /mobile node to /apps/settings/ and referred that path to cq:deviceGroups property in my page template.

Answers (2)

Answers (2)

Avatar

Avatar

chirags8739021

Avatar

chirags8739021

chirags8739021

09-07-2019

Same case with 6.4 as well.

no impact of updating the custom emulators on http://localhost:4502/etc/mobile/groups/responsive.html​​ but after updating /libs/settings/mobile/groups/responsive.html it works for me.

so overlayed /libs/settings/mobile to /apps/settings and updated the custom emulators at http://localhost:4502/apps/settings/mobile/groups/responsive.html

Regards,

Chirag S.

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

15-05-2019

You need to provide more detail to the community if you are asking why your customization to the AEM emulators is not working. What did you do to customize it. Please show in detail what you did.