org.apache.sling.servlets.get.impl.DefaultGetServlet No renderer for extension html, cannot render resource ResourceWrapper

Avatar

Avatar
Validate 10
Level 2
rajs73651622
Level 2

Likes

4 likes

Total Posts

42 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 2
rajs73651622
Level 2

Likes

4 likes

Total Posts

42 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 3
Boost 1
View profile
rajs73651622
Level 2

12-11-2019

I am getting below error. Can anyone please help me to resolve the below issue .

Getting in both AEM 6.4 and 6.5

org.apache.sling.servlets.get.impl.DefaultGetServlet No renderer for extension html, cannot render resource ResourceWrapper

Following the below link to register a form details into AEM  jcr:content.

Adobe Experience Manager Help | Persisting Adobe Experience Manager 6.4 JCR data using a Custom Form...

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 50
Employee
berliant
Employee

Likes

207 likes

Total Posts

315 posts

Correct reply

98 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Give Back 50
Employee
berliant
Employee

Likes

207 likes

Total Posts

315 posts

Correct reply

98 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
berliant
Employee

12-11-2019

Check Sling GET servlet configurtaion at http://<host>:<port>/system/console/configMgr/org.apache.sling.servlets.get.DefaultGetServlet

Make sure that Enable JSON and Enable XML are selected

Answers (5)

Answers (5)

Avatar

Avatar
Validate 10
Level 2
rajs73651622
Level 2

Likes

4 likes

Total Posts

42 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 2
rajs73651622
Level 2

Likes

4 likes

Total Posts

42 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 3
Boost 1
View profile
rajs73651622
Level 2

13-11-2019

Hi Jorg,

Thanks!! for looking the issue .

I have followed the below link to get some employee information and saving these details to /content /employees node .

Adobe Experience Manager Help | Persisting Adobe Experience Manager 6.4 JCR data using a Custom Form...

After submitting the form the node  is getting created but the properties are not getting added to the node .

Please suggest something  to resolve the issue .

ERROR

org.apache.sling.servlets.get.impl.DefaultGetServlet No renderer for extension html, cannot render resource ResourceWrapper

Avatar

Avatar
Level 1
hashdev0
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
hashdev0
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
hashdev0
Level 1

05-05-2021

I had the same issue and I applied all of those option which described here. 

 

The most working solution is restart your AEM instances. It would restart all the services back and would work. It worked for me. 

 

Cheers.

Avatar

Avatar
Seeker
Level 1
puneet_lamba
Level 1

Likes

2 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Seeker
Engage 1
Give Back
Boost 1
Applaud 5
View profile

Avatar
Seeker
Level 1
puneet_lamba
Level 1

Likes

2 likes

Total Posts

7 posts

Correct reply

0 solutions
Top badges earned
Seeker
Engage 1
Give Back
Boost 1
Applaud 5
View profile
puneet_lamba
Level 1

14-04-2020

I was seeing a similar issue. The Groovy Console stopped working and gave me the following error.

 

GET /apps/groovyconsole.html HTTP/1.1] org.apache.sling.servlets.get.impl.DefaultGetServlet
No renderer for extension html

 

Restarting AEM resolved the issue. But the Console started behaving erratically (script edit window not loading) after I visited the /apps/archetype13/config node in CRXDE. I noticed that even though I didn't make any changes to this node in CRXDE, after I load /apps/archetype13/config/org.apache.sling.commons.log.LogManager.factory.config-archetype13.config (by double-clicking on it) when I try to navigate away from CRXDE I get the question "Leave site? (Changes you made may not be saved.)". Even though I made no changes. After this the erratic behavior starts. 

 

As someone stated above, it's as if the resourceType resolution is failing and the request is reaching DefaultGetServlet. But not sure why that is happening. 

 

UPDATE:

My issue seems to have resolved itself after building with Oracle JDK 8 and running AEM with Oracle JDK 11. Previously I was building and running with OpenJDK because I couldn't find a way to install Oracle JDKs via Homebrew. So I gave in and used the Oracle installers. (Note: I use bash profile aliases to switch between Java versions. And somehow running AEM on Oracle JDK 8 causes issues, so I'm using Oracle JDK 11.)

Avatar

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,134 likes

Total Posts

3,161 posts

Correct reply

1,079 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,134 likes

Total Posts

3,161 posts

Correct reply

1,079 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile
Jörg_Hoh
Employee

12-11-2019

Can you please be more specific, what you did exactly when this log message shows up?

(Best guess: your node in the /content tree does not have a resourceType property. Or the resourceType does not exist.)

Jörg

Avatar

Avatar
Validate 10
Level 2
rajs73651622
Level 2

Likes

4 likes

Total Posts

42 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 2
rajs73651622
Level 2

Likes

4 likes

Total Posts

42 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Boost 3
Boost 1
View profile
rajs73651622
Level 2

12-11-2019

Both JSON and XML are selected in /system/console/configMgr/org.apache.sling.servlets.get.DefaultGetServletAfter that also not working .Could u please suggest something what can be the other way to resolve the issue.