org.apache.sling.servlets.get.impl.DefaultGetServlet No renderer for extension html, cannot render resource ResourceWrapper

rajs73651622

12-11-2019

I am getting below error. Can anyone please help me to resolve the below issue .

Getting in both AEM 6.4 and 6.5

org.apache.sling.servlets.get.impl.DefaultGetServlet No renderer for extension html, cannot render resource ResourceWrapper

Following the below link to register a form details into AEM  jcr:content.

Adobe Experience Manager Help | Persisting Adobe Experience Manager 6.4 JCR data using a Custom Form...

Answers (4)

Answers (4)

rajs73651622

13-11-2019

Hi Jorg,

Thanks!! for looking the issue .

I have followed the below link to get some employee information and saving these details to /content /employees node .

Adobe Experience Manager Help | Persisting Adobe Experience Manager 6.4 JCR data using a Custom Form...

After submitting the form the node  is getting created but the properties are not getting added to the node .

Please suggest something  to resolve the issue .

ERROR

org.apache.sling.servlets.get.impl.DefaultGetServlet No renderer for extension html, cannot render resource ResourceWrapper

puneet_lamba

14-04-2020

I was seeing a similar issue. The Groovy Console stopped working and gave me the following error.

 

GET /apps/groovyconsole.html HTTP/1.1] org.apache.sling.servlets.get.impl.DefaultGetServlet
No renderer for extension html

 

Restarting AEM resolved the issue. But the Console started behaving erratically (script edit window not loading) after I visited the /apps/archetype13/config node in CRXDE. I noticed that even though I didn't make any changes to this node in CRXDE, after I load /apps/archetype13/config/org.apache.sling.commons.log.LogManager.factory.config-archetype13.config (by double-clicking on it) when I try to navigate away from CRXDE I get the question "Leave site? (Changes you made may not be saved.)". Even though I made no changes. After this the erratic behavior starts. 

 

As someone stated above, it's as if the resourceType resolution is failing and the request is reaching DefaultGetServlet. But not sure why that is happening. 

 

UPDATE:

My issue seems to have resolved itself after building with Oracle JDK 8 and running AEM with Oracle JDK 11. Previously I was building and running with OpenJDK because I couldn't find a way to install Oracle JDKs via Homebrew. So I gave in and used the Oracle installers. (Note: I use bash profile aliases to switch between Java versions. And somehow running AEM on Oracle JDK 8 causes issues, so I'm using Oracle JDK 11.)

Jörg_Hoh

Employee

12-11-2019

Can you please be more specific, what you did exactly when this log message shows up?

(Best guess: your node in the /content tree does not have a resourceType property. Or the resourceType does not exist.)

Jörg

rajs73651622

12-11-2019

Both JSON and XML are selected in /system/console/configMgr/org.apache.sling.servlets.get.DefaultGetServletAfter that also not working .Could u please suggest something what can be the other way to resolve the issue.