org.apache.commons.lang3 can not be resolved in OSGI console.

sharathn8223803

14-01-2019

I have added the below dependency in the pom for my project.

<dependency>

    <groupId>org.apache.commons</groupId>

    <artifactId>commons-lang3</artifactId>

    <version>3.8.1</version>

</dependency>

But in System/console I am getting the below Error. Do i need to export the package. Please help.

org.apache.commons.lang3,version=[3.8,4) -- Cannot be resolved

Accepted Solutions (1)

Accepted Solutions (1)

Jörg_Hoh

Employee

14-01-2019

This maven dependency applies to an OSGI bundle, thus the version number applies to the bundle version.

OSGI dependencies apply to java package versions; sometimes all packages exported by a certain bundle have the same version as the bundle, but that's not often.

Check in your AEM instance, what version of the OSGI bundle "commons-lang3" you have deployed, and change the maven dependency to the same version.