Only Master Experience Fragment Variation is being shown in publish environment.

Avatar

Avatar
Validate 1
Level 1
vinodprathipati
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
vinodprathipati
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
vinodprathipati
Level 1

10-03-2021

Hi Team,

 

We have created different variants of experience fragments for header and footer and configured it for editable template pages.

 

Content is being shown in author as expected but publish content is only being showed with master variant. i have checked in publish and all related files & Fragments were published.

 

please let me know if you faced these kind of issues and pointers to fix this issue.

 

Environment: AEM 6.4

Service pack: 8

 

 

Accepted Solutions (0)

Answers (2)

Answers (2)

Avatar

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

484 likes

Total Posts

1,049 posts

Correct reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile

Avatar
Establish
MVP
Veena_Vikram
MVP

Likes

484 likes

Total Posts

1,049 posts

Correct reply

121 solutions
Top badges earned
Establish
Coach
Contributor 2
Seeker
Ignite 5
View profile
Veena_Vikram
MVP

12-03-2021

@vinodprathipati Can you check the node of the page where you have authored the experience fragment (XF) , and check if the property is rightly reflecting ? If not re-publish the content page (not XF) and check if it solving. It can only be a content issue as far as I could understand.

Avatar

Avatar
Coach
Employee
jbrar
Employee

Likes

389 likes

Total Posts

869 posts

Correct reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile

Avatar
Coach
Employee
jbrar
Employee

Likes

389 likes

Total Posts

869 posts

Correct reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile
jbrar
Employee

10-03-2021

Login to the publish instance with the admin user and check if the right version of content is available there. Most probably it is missing.

 

Another issue can be dispatcher flush not getting triggered which causes the dispatcher to show the old content.