NPM Error running -PautoInstallSinglePackage clean install following WKND project

Avatar

Avatar

PeytonHanel

Avatar

PeytonHanel

PeytonHanel

18-09-2020

I'm following the WKND project, and the problem I'm having doesn't seem to be very common so I'm not finding answers online. At first when I got to step 3 under Build the Project I ran the command mvn -PautoInstallSinglePackage clean install. The original error was happening at the (npm install) phase and gave me the following output. As you can see the first error is a segmentation fault without much detail.

 

[INFO] --- frontend-maven-plugin:1.7.6:npm (npm install) @ aem-guides-wknd.ui.frontend ---
[INFO] Running 'npm install' in /home/peyton/work/wknd-tutorial/aem-guides-wknd/ui.frontend
[WARNING] npm WARN deprecated tslint-webpack-plugin@2.1.0: Due to tslint being deprecated, this plugin is now also deprecated. Please consider switching to eslint.
[WARNING] npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
[WARNING] npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
[WARNING] npm WARN deprecated har-validator@5.1.5: this library is no longer supported
[WARNING] npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
[WARNING] npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
[WARNING] npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
[INFO]
[INFO] > node-sass@4.14.1 install /home/peyton/work/wknd-tutorial/aem-guides-wknd/ui.frontend/node_modules/node-sass
[INFO] > node scripts/install.js
[INFO]
[ERROR] Segmentation fault (core dumped)
[WARNING] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.1.2 (node_modules/chokidar/node_modules/fsevents):
[WARNING] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
[WARNING] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/watchpack-chokidar2/node_modules/chokidar/node_modules/fsevents):
[WARNING] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
[WARNING] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/webpack-dev-server/node_modules/chokidar/node_modules/fsevents):
[WARNING] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
[ERROR]
[ERROR] npm ERR! code ELIFECYCLE
[ERROR] npm ERR! errno 139
[ERROR] npm ERR! node-sass@4.14.1 install: `node scripts/install.js`
[ERROR] npm ERR! Exit status 139
[ERROR] npm ERR!
[ERROR] npm ERR! Failed at the node-sass@4.14.1 install script.
[ERROR] npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
[ERROR]
[ERROR] npm ERR! A complete log of this run can be found in:
[ERROR] npm ERR! /home/peyton/.npm/_logs/2020-09-18T13_27_36_313Z-debug.log
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary for aem-guides-wknd 0.0.1-SNAPSHOT:
[INFO]
[INFO] aem-guides-wknd .................................... SUCCESS [ 0.171 s]
[INFO] WKND Sites Project - Core .......................... SUCCESS [ 3.722 s]
[INFO] WKND Sites Project - UI Frontend ................... FAILURE [ 11.658 s]
[INFO] WKND Sites Project - Repository Structure Package .. SKIPPED
[INFO] WKND Sites Project - UI apps ....................... SKIPPED
[INFO] WKND Sites Project - UI content .................... SKIPPED
[INFO] WKND Sites Project - All ........................... SKIPPED
[INFO] WKND Sites Project - Integration Tests Bundles ..... SKIPPED
[INFO] WKND Sites Project - Integration Tests Launcher .... SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE

I resolved this error by going to the ui.frontend folder and running npm install manually there. The next error I received after this came at the (npm run prod) stage, specifically after this line in the output: 
webpack -p --config ./webpack.prod.js && clientlib --verbose
and I noticed that webpack wasn't even a command, so I used apt to install it. I also noticed I was unable to run clientlib as it was, but instead I have to run it by navigating to aem-guides-wknd/ui.frontend/node_modules/aem-clientlib-generator/bin/clientlib-cli.js. But that doesn't help me because that's not where npm run prod is going to run it.

At the moment this is the output that npm run prod is giving me, and there are more segfaults. I need somebody to help me resolve these issues please since I am unsure as to what to do at the moment.

[INFO] --- frontend-maven-plugin:1.7.6:npm (npm run prod) @ aem-guides-wknd.ui.frontend ---
[INFO] Running 'npm run prod' in /home/peyton/work/wknd-tutorial/aem-guides-wknd/ui.frontend
[INFO]
[INFO] > aem-maven-archetype@1.0.0 prod /home/peyton/work/wknd-tutorial/aem-guides-wknd/ui.frontend
[INFO] > webpack -p --config ./webpack.prod.js && clientlib --verbose
[INFO]
[ERROR] Segmentation fault (core dumped)
[ERROR] npm ERR! code ELIFECYCLE
[ERROR] npm ERR! errno 139
[ERROR] npm ERR! aem-maven-archetype@1.0.0 prod: `webpack -p --config ./webpack.prod.js && clientlib --verbose`
[ERROR] npm ERR! Exit status 139
[ERROR] npm ERR!
[ERROR] npm ERR! Failed at the aem-maven-archetype@1.0.0 prod script.
[ERROR] npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
[ERROR]
[ERROR] npm ERR! A complete log of this run can be found in:
[ERROR] npm ERR! /home/peyton/.npm/_logs/2020-09-18T14_15_11_167Z-debug.log
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary for aem-guides-wknd 0.0.1-SNAPSHOT:
[INFO]
[INFO] aem-guides-wknd .................................... SUCCESS [ 0.146 s]
[INFO] WKND Sites Project - Core .......................... SUCCESS [ 3.486 s]
[INFO] WKND Sites Project - UI Frontend ................... FAILURE [ 3.762 s]
[INFO] WKND Sites Project - Repository Structure Package .. SKIPPED
[INFO] WKND Sites Project - UI apps ....................... SKIPPED
[INFO] WKND Sites Project - UI content .................... SKIPPED
[INFO] WKND Sites Project - All ........................... SKIPPED
[INFO] WKND Sites Project - Integration Tests Bundles ..... SKIPPED
[INFO] WKND Sites Project - Integration Tests Launcher .... SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------

-PautoInstallSinglePackage npm error npm install npm run prod wknd
View Entire Topic

Avatar

Avatar

ChitraMadan

MVP

Avatar

ChitraMadan

MVP

ChitraMadan
MVP

20-09-2020

Hi @PeytonHanel ,

 

Looks like there is some problem with your installed node and npm.

 

Can you please uninstall and install them again.

 

https://stackoverflow.com/questions/56050531/after-upgrading-node-segmentation-fault-core-dumped-err...