Not able to see Workflow Model in aem 6.5

Avatar

Avatar

tushaar_srivastava

Avatar

tushaar_srivastava

tushaar_srivastava

25-08-2020

Hi Team,
I am not able to see the workflow model instead I have created many model, not sure why this is showing blank.

Not sure how to debug this

tushaars9735484_1-1598344749918.png

 

@kautuk_sahni @Arun_Patidar 

 

aem6.5 models workflow workflow activities

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Vijayalakshmi_S

MVP

Avatar

Vijayalakshmi_S

MVP

Vijayalakshmi_S
MVP

25-08-2020

Hi @tushaar_srivastava,

Workflow models rendering logic

In Classic UI is /libs/cq/workflow/components/console/models/options.json.jsp 

In Touch UI is /libs/cq/workflow/admin/console/components/datasource/modelsdatasource/modelsdatasource.jsp

Both retrieves models from WorkflowSession but former from com.day.cq.workflow.* API and latter using com.adobe.granite.workflow.*

 

Given that problem is in Touch UI alone, per the logic you should see a log message in error.log - "Error while retrieving workflow models." (Screenshot below)

Also you have mentioned that you have tried creating many new models, can you check where it got created. Is it under /var or /etc (if its fresh 6.5 instance, it should be in /var)

Vijayalakshmi_S_0-1598358061803.png

 

tushaar_srivastava
it is under /var
tushaar_srivastava

I can see in my logs

*ERROR* [sling-threadpool-ed45eed2-832a-447b-b5d0-fe409fea7198-(com.day.cq.wcm.workflow.impl.wcmworkflowserviceimpl)-6] com.day.cq.wcm.workflow.impl.WorkflowAutoAssignAllocator Unable to read all workflow auto assign rules: /etc/workflow/wcm/templates

 

*ERROR* [sling-threadpool-ed45eed2-832a-447b-b5d0-fe409fea7198-(com.day.cq.wcm.workflow.impl.wcmworkflowserviceimpl)-6] com.day.cq.wcm.workflow.impl.WorkflowAutoAssignAllocator Unable to read all workflow auto assign rules: /etc/workflow/wcm/templates

Vijayalakshmi_S

Hi @tushaar_srivastava,

Save a copy of existing error.log file -> Clear the contents of existing log entries -> access Workflow models console in Touch UI once again and observe the logs. 

Also can you confirm

  • there is no workflow models in /etc. All workflow models resides in /var only
  • If it is a fresh install or in-place upgraded instance
tushaar_srivastava
Hi @Vijayalakshmi_S I tried to clear error.log and checked, I have deleted one Workflow Model from CRX that was under /var and /conf folder and because of this manually deleting the model, affected on the WF Model screen as per attached above. when I checked log and created the same model in Local and uploaded it into the local where this error was coming, then it got resolved, still wondering by deleting the WF Model from /var & /conf from CRX how this affected?
Vijayalakshmi_S

Hi @tushaar_srivastava,

You mean to say all OOB models and any custom models are in /etc and deleting things from /var and /conf help reflect the same in Models console?

Sorry, I couldn't follow the steps you have tried per your last comment.

tushaar_srivastava
I created a WF Model though WF console and can see the node created under /var and /conf and if manually we delete those WF through CRX in that case this WF Model console is blank. and when I again created the WF which I deleted in different Local and uploaded into the local where we were seeing issue, then it worked.
Vijayalakshmi_S

Hi @tushaar_srivastava,

Can you let know below details to narrow down the cause further.

  • If your 6.5 instance is fresh install or in-place upgraded instance. 
  • Was there any migration activity related to workflows
  • At present where the OOB workflows residing in your instance? Is it in /etc or /conf and /var
  • Background on from when it was not working. 

Answers (4)

Answers (4)

Avatar

Avatar

knitshweta

Avatar

knitshweta

knitshweta

27-08-2020

My first question is after deleting how did u create this model? Was it via code deployment or via workflow console?

Either way, when you create the model you will definitely see it in /conf.

You just have to make sure it exists in /var also.

If not, just open http://localhost:4502/cf#/conf/settings/workflow/models/my-model.html  

manually and save it. This will create a /var node then you will be able to see the model.

 

Avatar

Avatar

Varun_Shakya

MVP

Avatar

Varun_Shakya

MVP

Varun_Shakya
MVP

25-08-2020

This is one similar thread 

https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/aem-6-4-could-not-find-mod...

 

Check the comments provided by Hemant .

 

Avatar

Avatar

vanegi

Employee

Avatar

vanegi

Employee

vanegi
Employee

25-08-2020

Hi @tushaar_srivastava,

Do you see any error in AEM error.log when you hit the workflow model screen, please share the logs?

 

Thanks!!

tushaar_srivastava
I tried to refactor(beautify) this log but seems it is not accepting in comments. Could you please check this one
tushaar_srivastava
*INFO* [sling-default-4-com.adobe.cq.wcm.translation.impl.scheduler.ScheduleRepeatTranslationProject] com.adobe.cq.wcm.translation.impl.scheduler.ScheduleRepeatTranslationProject Starting sync process now *INFO* [sling-default-2-com.adobe.granite.threaddump.impl.BackupCleaner] com.adobe.granite.threaddump.impl.BackupCleaner Cleaning backup(s) older than 7 days, starting from Tue Aug 18 00:00:00 PDT 2020... *INFO* [sling-default-2-com.adobe.granite.threaddump.impl.BackupCleaner] com.adobe.granite.threaddump.impl.BackupCleaner All backup(s) successfully removed. *INFO* [sling-default-2-com.day.cq.dam.similaritysearch.internal.scheduler.PeriodicAutoTaggingJob.7934] com.day.cq.dam.similaritysearch.internal.scheduler.PeriodicAutoTaggingJob Smart Tags not configured. Ignoring periodic job. *INFO* [sling-default-4-com.adobe.cq.wcm.translation.impl.scheduler.ScheduleRepeatTranslationProject] com.adobe.cq.wcm.translation.impl.scheduler.ScheduleRepeatTranslationProject Sync process complete *INFO* [sling-default-5-com.day.cq.dam.core.impl.ExpiryNotificationJobImpl] com.day.cq.dam.core.impl.ExpiryNotificationJobImpl No assets passed to deactivate. *INFO* [sling-default-4-health-org.apache.sling.discovery.oak.SynchronizedClocksHealthCheck] org.apache.sling.discovery.oak.SynchronizedClocksHealthCheck execute: no topology connectors connected to local instance. *ERROR* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] org.apache.sling.servlets.get.impl.DefaultGetServlet No renderer for extension html, cannot render resource SyntheticResource, type=cq/analytics/components/analytics, path=/content/www/us/en/test/ ****/jcr:content/analytics *INFO* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] com. ****.wwww.tags.***TmsTag Inside ArkTmsTag doTag() *INFO* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] apps. ****.components.content.reference.reference$jsp target paragraph value /content/data/globalcontent/US/en/### *INFO* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] apps. ****.components.content.reference.reference$jsp target paragraph value /content/data/globalcontent/US/en/### *INFO* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] apps. ****.components.content.reference.reference$jsp target paragraph value /content/data/globalcontent/US/en/### *INFO* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] apps. ****.components.content.reference.reference$jsp target paragraph value /content/data/globalcontent/US/en/### *INFO* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] com. ****.dynamicdelivery.DDRelevanceEngine ######### DD Engine Settings :: Boosting Weights: 600, 400 , 20 , 10 , 3 *INFO* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] com. ****.dynamicdelivery.DDRelevanceEngine ######### DD Engine query >> SELECT Path FROM [cq:PageContent] AS s WHERE ((( CONTAINS(tagsAudiencePrimary,'testaudience:corporate') OR CONTAINS(tagsAudienceSecondary,'testaudience:corporate') )) OR NOT tagsAudiencePrimary IS NOT NULL ) AND ( [cq:template]='/apps/ ****/templates/****' OR [cq:template]='/apps/ ****/templates/****' ) AND ( CONTAINS(tagsPrimary,'rmwwwwetingtest: ****/ ****core ****^400 OR emtsystemtype:smartphones^20' ) OR CONTAINS(tagsSecondary, 'emtsystemtype:smartphones^10 OR rmwwwwetingtest: ****/ ****core ****^20' ) ) *INFO* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] com. ****.common.util.QueryUtil Served dynamic delivery results from cache: /content/www/us/en/test/ ****/jcr:content/bladepar/relatedmaterials Cache key: relatedmaterials *INFO* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] com. ****.dynamicdelivery.DDRelevanceEngine results are ::[/content/www/us/en/test/docs/ ****/performance-maximizer, /content/www/us/en/test/docs/ ****, /content/www/us/en/test/docs/ ****, /content/www/us/en/test/docs/ ****] *INFO* [10.235.167.83 [1598338809257] GET /content/www/us/en/test/ ****.html HTTP/1.1] apps. ****.components.content.reference.reference$jsp target paragraph value null *INFO* [sling-default-1- **** Product Specification Page Cache clear] org.apache.commons.httpclient.HttpMethodDirector I/O exception (java.net.ConnectException) caught when processing request: Connection timed out: connect *INFO* [sling-default-1- **** Product Specification Page Cache clear] org.apache.commons.httpclient.HttpMethodDirector Retrying request *ERROR* [10.235.167.83 [1598338817062] GET /content/US/en/globalnav4.newnav.html HTTP/1.1] com. ****.wcm.api.ui.tags. ****HeaderFooter.simplify.MegaMenuTag MegaMenuTag doTag problem: java.lang.NullPointerException: null *ERROR* [sling-threadpool-ed45eed2-832a-447b-b5d0-fe409fea7198-(com.day.cq.wcm.workflow.impl.wcmworkflowserviceimpl)-6] com.day.cq.wcm.workflow.impl.WorkflowAutoAssignAllocator Unable to read all workflow auto assign rules: /etc/workflow/wcm/templates *ERROR* [sling-threadpool-ed45eed2-832a-447b-b5d0-fe409fea7198-(com.day.cq.wcm.workflow.impl.wcmworkflowserviceimpl)-6] com.day.cq.wcm.workflow.impl.WorkflowAutoAssignAllocator Unable to read all workflow auto assign rules: /etc/workflow/wcm/templates *WARN* [10.5.174.169 [1598338827482] GET /editor.html/content/www/us/en/_data_image/jpeg;base64,/9j/4QAYRXhpZgAASUkqAAgAAAAAAAAAAAAAAP/+7vyIgaWQ9Ilc1TTBNcENlaGlIenJlU3pOVGN6a2M5ZCI/+/Pv/uAA5BZG9iZQBkwAAAAAH///AABEIAHoAegMBEQACEQEDEQH//2gAMAwEAAhEDEQA/APeO4jt8eLcBrnixHixYsWsWpuLFiM+OLEfjXvszM3mY6eewI++Nw11jICpvjcFgKm+= HTTP/1.1] com.adobe.cq.xf.impl.servlet.rendercondition.EditorRenderCondition Page at path /content/www/us/en/_data_image/jpeg/9j/= doesn't have a jcr:content node *ERROR* [10.5.174.169 [1598338827845] GET /content/www/us/en/randomtest.html HTTP/1.1] org.apache.sling.servlets.get.impl.DefaultGetServlet No renderer for extension html, cannot render resource SyntheticResource, type=cq/analytics/components/analytics, path=/content/www/us/en/randomtest/jcr:content/analytics *INFO* [10.5.174.169 [1598338827845] GET /content/www/us/en/randomtest.html HTTP/1.1] com. ****. ****suite.tags. ****TmsTag Inside ****TmsTag doTag() *ERROR* [10.5.174.169 [1598338827845] GET /content/www/us/en/randomtest.html HTTP/1.1] com. ****. ****.tags. **** Exception in **** doTag:: java.lang.NullPointerException: null

Avatar

Avatar

Nikhil-Kumar

MVP

Avatar

Nikhil-Kumar

MVP

Nikhil-Kumar
MVP

25-08-2020

@tushaar_srivastava - Are you able to see it in classic version ?