Not able to run local dispatcher on Windows 10 Pro

Avatar

Avatar
Validate 1
Level 1
imalakaamir
Level 1

Likes

0 likes

Total Posts

6 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
imalakaamir
Level 1

Likes

0 likes

Total Posts

6 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
imalakaamir
Level 1

29-06-2021

Hi Guys,

 

Getting error "Required image not found, trying to load from archive...  unsupported os linux" when tried setting up Dispatcher locally. I have made sure Docker is up and running but still the error. 

 

I am following below doc from Adobe and using AEM as cloud service

 

https://experienceleague.adobe.com/docs/experience-manager-learn/cloud-service/local-development-env...

 

 

Appreciate help and Thanks in advance, below are is what i see when commands ran on cmd windows 10 pro

 

C:\aem-instances\dispatcher>bin\validator full -d out src
Cloud manager validator 2.0.32
2021/06/30 14:57:17 No issues found
2021/06/30 14:57:17 Dump folder already exists and non-empty: out

C:\aem-instances\dispatcher>bin\docker_run out host.docker.internal:4503 8080
values.csv found in deployment folder: C:\aem-instances\dispatcher\out - using files listed there
Required image not found, trying to load from archive...
unsupported os linux

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Affirm 25
Level 5
Bimmi_Soi
Level 5

Likes

79 likes

Total Posts

83 posts

Correct reply

28 solutions
Top badges earned
Affirm 25
Contributor
Applaud 5
Boost 50
Ignite 1
View profile

Avatar
Affirm 25
Level 5
Bimmi_Soi
Level 5

Likes

79 likes

Total Posts

83 posts

Correct reply

28 solutions
Top badges earned
Affirm 25
Contributor
Applaud 5
Boost 50
Ignite 1
View profile
Bimmi_Soi
Level 5

30-06-2021

Hi @imalakaamir ,

Please remove hyphen from aem-instances folder and run the command again.

else Please go through the below blog

https://bimmisoi.blogspot.com/2021/05/local-dispatcher-setup-aem-as-cloud-on.html

 

Hope it helps

Thanks

 

Answers (1)

Answers (1)

Avatar

Avatar
Boost 5
Level 7
Ritesh_M
Level 7

Likes

179 likes

Total Posts

142 posts

Correct reply

45 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Boost 5
Level 7
Ritesh_M
Level 7

Likes

179 likes

Total Posts

142 posts

Correct reply

45 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
Ritesh_M
Level 7

30-06-2021

Hi @imalakaamir ,

 

Though I believe you must have noticed but in case if missed -

 

"Windows users cannot have any spaces or special characters in the path to the folder containing the Local Dispatcher Tools."

Also, try running command prompt/power shell as administrator. Try using latest/different SDK.