Not able to move content using VLT-RCP in AEM 6.3

Avatar

Avatar
Boost 3
Level 2
chitranshs90502
Level 2

Likes

3 likes

Total Posts

14 posts

Correct reply

0 solutions
Top badges earned
Boost 3
Give Back
Ignite 1
Boost 1
Validate 1
View profile

Avatar
Boost 3
Level 2
chitranshs90502
Level 2

Likes

3 likes

Total Posts

14 posts

Correct reply

0 solutions
Top badges earned
Boost 3
Give Back
Ignite 1
Boost 1
Validate 1
View profile
chitranshs90502
Level 2

03-12-2019

Hi,

I am getting following error:

org.apache.jackrabbit.vault.util.RepositoryCopier Error while retrieving src node /content/we-retail-vlt: javax.jcr.PathNotFoundException: /content/we-retail-vlt

we-retail-vlt is the content folder I am trying to move from one author environment to another author environment. I have org.apache.jackrabbit.vault.rcp 3.1.40 bundle activated.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Give Back 50
Employee
Vish_dhaliwal
Employee

Likes

189 likes

Total Posts

356 posts

Correct reply

123 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
Vish_dhaliwal
Employee

05-12-2019

Please provide the exact copy command.

Here is an example of working command:

vlt rcp -b 100 -e -r -q -u http://admin:admin@localhost:4522/crx/-/jcr:root/content/geometrixx0 http://admin:admin@localhost:4509/crx/-/jcr:root/content/geometrixx0

Just try once with VLT RCP tool created by ACS Commons [1].

[1] http://adobe-consulting-services.github.io/acs-aem-tools/features/vlt-rcp/index.html

Regards,

Vishu

Answers (2)

Answers (2)

Avatar

Avatar
Level 1
chitranshs92047
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
chitranshs92047
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
chitranshs92047
Level 1

04-12-2019

Hi,

-  User is admin only.

- In have Setup Debug logger and getting below error:

  1. 05.12.2019 07:08:33.621 *INFO* [Vault RCP Task - task6] org.apache.jackrabbit.vault.rcp.impl.RcpTask Starting repository copy task id=t

ask6. From <https://*****:4502/crx/server/crx.default/jcr:root/content/we-retail-vlt to /content/we-retail-vlt>.

  1. 05.12.2019 07:08:33.628 *ERROR* [Vault RCP Task - task6] org.apache.jackrabbit.vault.util.RepositoryCopier Error while retrieving src n

ode /content/we-retail-vlt: javax.jcr.PathNotFoundException: /content/we-retail-vlt

Avatar

Avatar
Coach
Employee
jbrar
Employee

Likes

389 likes

Total Posts

869 posts

Correct reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile

Avatar
Coach
Employee
jbrar
Employee

Likes

389 likes

Total Posts

869 posts

Correct reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile
jbrar
Employee

04-12-2019

Can you check the following:

- Which user are you using for the transfer? Try using "admin" user and check if you get the same issue.

- Setup a DEBUG logger on "org.apache.jackrabbit.vault" to get more details about the failure.