Not able to deploy UI.Apps package - Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved

Avatar

Avatar

veemat1

Avatar

veemat1

veemat1

02-09-2020

Hello,

I am trying to work with aem-guides-wknd repository and getting below error deplying UI.apps

 

aem-guides-wknd\ui.apps>mvn -PautoInstallPackage clean install


[INFO] Scanning for projects...
[WARNING] The POM for com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2 is missing, no dependency information available
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failure to find com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2 in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced @
[ERROR] Unknown packaging: content-package @ line 34, column 16
@
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]
[ERROR] The project com.adobe.aem.guides:aem-guides-wknd.ui.apps:0.0.1-SNAPSHOT (C:\Users\dev\code\aem-guides-wknd\ui.apps\pom.xml) has 2 errors
[ERROR] Unresolveable build extension: Plugin com.day.jcr.vault:content-package-maven-plugin:1.0.2 or one of its dependencies could not be resolved: Failure to find com.day.jcr.vault:content-package-maven-plugin:jar:1.0.2 in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced -> [Help 2]
[ERROR] Unknown packaging: content-package @ line 34, column 16
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/PluginManagerException

 

Any help greatly appreciated.

 

Thanks

Veemat

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

veemat1

Avatar

veemat1

veemat1

02-09-2020

For any one who might be interested. This command solved the problem

mvn -PautoInstallPackage -Padobe-public clean install

Answers (1)

Answers (1)

Avatar

Avatar

BrianKasingli

MVP

Avatar

BrianKasingli

MVP

BrianKasingli
MVP

02-09-2020

@veemat1,

Your settings.xml may not be set up properly. Try to configure settings from this page https://helpx.adobe.com/uk/experience-manager/kb/SetUpTheAdobeMavenRepository.html. Or if the weekend tutorial is using the maven archetype as the project base, and assuming that the adobePublic project exists, you can build your code with mvn -Padobe-public clean install -PadobePublic